summaryrefslogtreecommitdiffstats
path: root/doc/extdev
diff options
context:
space:
mode:
Diffstat (limited to 'doc/extdev')
-rw-r--r--doc/extdev/appapi.rst3
-rw-r--r--doc/extdev/deprecated.rst14
-rw-r--r--doc/extdev/i18n.rst4
-rw-r--r--doc/extdev/nodes.rst2
-rw-r--r--doc/extdev/utils.rst6
5 files changed, 26 insertions, 3 deletions
diff --git a/doc/extdev/appapi.rst b/doc/extdev/appapi.rst
index 270000b..10d030b 100644
--- a/doc/extdev/appapi.rst
+++ b/doc/extdev/appapi.rst
@@ -443,6 +443,9 @@ The Config object
.. autoclass:: Config
+.. py:class:: ENUM
+ :no-typesetting:
+
.. _template-bridge:
diff --git a/doc/extdev/deprecated.rst b/doc/extdev/deprecated.rst
index f90389c..1476ce8 100644
--- a/doc/extdev/deprecated.rst
+++ b/doc/extdev/deprecated.rst
@@ -22,6 +22,20 @@ The following is a list of deprecated interfaces.
- Removed
- Alternatives
+ * - ``sphinx.testing.util.strip_escseq``
+ - 7.3
+ - 9.0
+ - ``sphinx.util.console.strip_colors``
+
+ * - Old-style Makefiles in ``sphinx-quickstart``
+ and the :option:`!-M`, :option:`!-m`, :option:`!--no-use-make-mode`,
+ and :option:`!--use-make-mode` options
+ - 7.3
+ - 9.0
+ - Vendoring the `old style Makefile templates`__
+
+ __ https://github.com/sphinx-doc/sphinx/blob/v7.0.0/sphinx/templates/quickstart/Makefile_t
+
* - ``sphinx.ext.autodoc.preserve_defaults.get_function_def()``
- 7.2
- 9.0
diff --git a/doc/extdev/i18n.rst b/doc/extdev/i18n.rst
index 6b32b8b..c5ffc84 100644
--- a/doc/extdev/i18n.rst
+++ b/doc/extdev/i18n.rst
@@ -18,8 +18,8 @@ i18n API
.. _ext-i18n:
-Extension internationalization (`i18n`) and localization (`l10n`) using i18n API
---------------------------------------------------------------------------------
+Extension internationalization (``i18n``) and localization (``l10n``) using i18n API
+------------------------------------------------------------------------------------
.. versionadded:: 1.8
diff --git a/doc/extdev/nodes.rst b/doc/extdev/nodes.rst
index 7603763..f17c28e 100644
--- a/doc/extdev/nodes.rst
+++ b/doc/extdev/nodes.rst
@@ -44,7 +44,7 @@ to ``docutils.nodes.inline`` by :py:class:`!SigElementFallbackTransform`.
Extensions may create additional ``desc_sig_*``-like nodes but in order for
:py:class:`!SigElementFallbackTransform` to translate them to inline nodes
automatically, they must be added to :py:data:`SIG_ELEMENTS` via the class
-keyword argument `_sig_element=True` of :py:class:`desc_sig_element`, e.g.:
+keyword argument ``_sig_element=True`` of :py:class:`desc_sig_element`, e.g.:
.. code-block:: python
diff --git a/doc/extdev/utils.rst b/doc/extdev/utils.rst
index e842f30..ff8dc4e 100644
--- a/doc/extdev/utils.rst
+++ b/doc/extdev/utils.rst
@@ -35,3 +35,9 @@ Utility components
.. autoclass:: sphinx.events.EventManager
:members:
+
+Utility types
+-------------
+
+.. autoclass:: sphinx.util.typing.ExtensionMetadata
+ :members: