summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:43:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:43:34 +0000
commit0fcce96a175531ec6042cde1b11a0052aa261dd5 (patch)
tree898a1e161c4984b41e6a732866bd73b24f0f7b7a /Makefile
parentInitial commit. (diff)
downloadsuricata-update-0fcce96a175531ec6042cde1b11a0052aa261dd5.tar.xz
suricata-update-0fcce96a175531ec6042cde1b11a0052aa261dd5.zip
Adding upstream version 1.3.2.upstream/1.3.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..577b562
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,50 @@
+.PHONY: doc
+
+all: build
+
+build:
+ python setup.py build
+
+install:
+ python setup.py install
+
+tox:
+ @if ! which tox 2>&1 > /dev/null; then \
+ echo "error: tox required to run tests"; \
+ exit 1; \
+ fi
+
+test: tox
+ @tox
+
+integration-test: tox
+ @tox -c tox-integration.ini
+
+docker-test:
+ @if ! which docker 2>&1 > /dev/null; then \
+ echo "error: docker is required to run docker tests"; \
+ exit 1; \
+ fi
+ @for test in $(wildcard tests/docker*); do \
+ (cd $$test && $(MAKE)); \
+ done
+
+clean:
+ find . -name \*.pyc -print0 | xargs -0 rm -f
+ find . -name \*~ -print0 | xargs -0 rm -f
+ find . -name __pycache__ -type d -print0 | xargs -0 rm -rf
+ rm -rf suricata_update.egg*
+ rm -rf build dist MANIFEST
+ cd doc && $(MAKE) clean
+
+doc:
+ cd doc && $(MAKE) clean html
+
+sdist:
+ python setup.py sdist
+
+sdist-upload:
+ python setup.py sdist upload
+
+update-index:
+ python -m suricata.update.data.update