summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1b27e99
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=suricata-update
+
+mandir := $(CURDIR)/debian/man
+debfolder := $(CURDIR)/debian
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_clean:
+ rm -rf $(mandir) tests/tmp
+ dh_auto_clean --
+
+override_dh_installman:
+ mkdir -p $(mandir)
+ help2man --include=debian/include-link.txt --no-discard-stderr -N -n 'tool to update Suricata sources' bin/suricata-update > $(mandir)/suricata-update.1
+ dh_installman --
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=. py.test-3
+endif