summaryrefslogtreecommitdiffstats
path: root/tests/test_net.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_net.py')
-rw-r--r--tests/test_net.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/test_net.py b/tests/test_net.py
new file mode 100644
index 0000000..ae5728c
--- /dev/null
+++ b/tests/test_net.py
@@ -0,0 +1,31 @@
+# Copyright (C) 2017 Open Information Security Foundation
+# Copyright (c) 2013 Jason Ish
+#
+# You can copy, redistribute or modify this Program under the terms of
+# the GNU General Public License version 2 as published by the Free
+# Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+# 02110-1301, USA.
+
+from __future__ import print_function
+
+import os
+import unittest
+import io
+
+from suricata.update import net
+
+class GetTestCase(unittest.TestCase):
+
+ def test_get0(self):
+ buf = io.BytesIO()
+ bytes_read, info = net.get("file:///%s/Makefile" % (os.getcwd()), buf)
+ self.assertTrue(b"clean" in buf.getvalue())