summaryrefslogtreecommitdiffstats
path: root/debian/patches/llc.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:52 +0000
commita95cd20bb8e569c5a5f43808555e90ea436b858f (patch)
tree7fb27265ca110c329d4d42336c979cab09fff04e /debian/patches/llc.patch
parentAdding upstream version 1:7.0.3. (diff)
downloadsuricata-debian/1%7.0.3-1.tar.xz
suricata-debian/1%7.0.3-1.zip
Adding debian version 1:7.0.3-1.debian/1%7.0.3-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/llc.patch')
-rw-r--r--debian/patches/llc.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/llc.patch b/debian/patches/llc.patch
new file mode 100644
index 0000000..dc0bf38
--- /dev/null
+++ b/debian/patches/llc.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -473,11 +473,12 @@
+ [
+ AS_IF([test "$CLANG" != no],
+ [
+- llc_candidates=$($CLANG --version | sed -e 's/.*clang version/clang version/' | \
+- awk '/^clang version/ {
+- split($3, v, ".");
+- printf("llc-%s.%s llc-%s llc", v[[1]], v[[2]], v[[1]])
+- }')
++ #llc_candidates=$($CLANG --version | sed -e 's/.*clang version/clang version/' | \
++ # awk '/^clang version/ {
++ # split($3, v, ".");
++ # printf("llc-%s.%s llc-%s llc", v[[1]], v[[2]], v[[1]])
++ # }')
++ llc_candidates=llc
+ AC_CHECK_PROGS([LLC], [$llc_candidates], "no")
+ if test "$LLC" = "no"; then
+ AC_MSG_ERROR([unable to find any of $llc_candidates needed to build ebpf files])