summaryrefslogtreecommitdiffstats
path: root/doc/userguide/conf.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-24 01:56:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-24 01:56:35 +0000
commitea7b101b409c45955f5d5446bb3bfdf7758b9226 (patch)
treeaca5d4fbf94bc524c392a5dd9cf4571f3a29ccb8 /doc/userguide/conf.py
parentAdding upstream version 1:7.0.4. (diff)
downloadsuricata-ea7b101b409c45955f5d5446bb3bfdf7758b9226.tar.xz
suricata-ea7b101b409c45955f5d5446bb3bfdf7758b9226.zip
Adding upstream version 1:7.0.5.upstream/1%7.0.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/userguide/conf.py')
-rw-r--r--doc/userguide/conf.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/doc/userguide/conf.py b/doc/userguide/conf.py
index d043a28..959744e 100644
--- a/doc/userguide/conf.py
+++ b/doc/userguide/conf.py
@@ -19,6 +19,10 @@ import re
import subprocess
import datetime
+# Set 'today'. This will be used as the man page date. If an empty
+# string todays date will be used.
+today = os.environ.get('RELEASE_DATE', '')
+
on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
# If extensions (or modules to document with autodoc) are in another directory,
@@ -67,7 +71,7 @@ try:
version = os.environ.get('version', None)
if not version:
version = re.search(
- "AC_INIT\(\[suricata\],\s*\[(.*)?\]\)",
+ r"AC_INIT\(\[suricata\],\s*\[(.*)?\]\)",
open("../../configure.ac").read()).groups()[0]
if not version:
version = "unknown"