summaryrefslogtreecommitdiffstats
path: root/qa/coccinelle/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /qa/coccinelle/Makefile.am
parentInitial commit. (diff)
downloadsuricata-upstream/1%7.0.3.tar.xz
suricata-upstream/1%7.0.3.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'qa/coccinelle/Makefile.am')
-rw-r--r--qa/coccinelle/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/qa/coccinelle/Makefile.am b/qa/coccinelle/Makefile.am
new file mode 100644
index 0000000..1f78a74
--- /dev/null
+++ b/qa/coccinelle/Makefile.am
@@ -0,0 +1,22 @@
+EXTRA_DIST= access-pkt-packet.cocci \
+ banned-functions.cocci \
+ direct-packet.cocci \
+ malloc-error-check.cocci \
+ pktnotset-packet.cocci \
+ realloc.cocci \
+ siginit.cocci \
+ size_t.cocci \
+ sz3.cocci \
+ uint.cocci \
+ run_check.sh struct-flags.py
+
+if HAVE_COCCINELLE
+struct-flags.cocci:
+ $(srcdir)/struct-flags.py $(top_srcdir)/src > $(top_builddir)/qa/coccinelle/struct-flags.cocci
+
+check: struct-flags.cocci
+ TOP_BUILDDIR=${abs_top_builddir} TOP_SRCDIR=$(abs_top_srcdir) $(top_srcdir)/qa/coccinelle/run_check.sh
+
+distclean-local:
+ -rm $(top_builddir)/qa/coccinelle/struct-flags.cocci
+endif