summaryrefslogtreecommitdiffstats
path: root/rust/vendor/proc-macro-crate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/proc-macro-crate
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/proc-macro-crate')
-rw-r--r--rust/vendor/proc-macro-crate/.cargo-checksum.json1
-rw-r--r--rust/vendor/proc-macro-crate/Cargo.toml36
-rw-r--r--rust/vendor/proc-macro-crate/LICENSE-APACHE201
-rw-r--r--rust/vendor/proc-macro-crate/LICENSE-MIT23
-rw-r--r--rust/vendor/proc-macro-crate/README.md58
-rw-r--r--rust/vendor/proc-macro-crate/src/lib.rs335
6 files changed, 654 insertions, 0 deletions
diff --git a/rust/vendor/proc-macro-crate/.cargo-checksum.json b/rust/vendor/proc-macro-crate/.cargo-checksum.json
new file mode 100644
index 0000000..c9e75f0
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"31bbd9fe7e0ebb23445ac4ae0afc0ee7536dee282f5bdb2595c6d7aa14af0b05","LICENSE-APACHE":"8ada45cd9f843acf64e4722ae262c622a2b3b3007c7310ef36ac1061a30f6adb","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"c39729d01487de048ba0cb776a809460b3b119ed933a34f0c3889223efdb451f","src/lib.rs":"def7641a7a8f18df9c83785930aed4812500494fe8dff09a3709b7a7d1c32e43"},"package":"1ebace6889caf889b4d3f76becee12e90353f2b8c7d875534a71e5742f8f6f83"} \ No newline at end of file
diff --git a/rust/vendor/proc-macro-crate/Cargo.toml b/rust/vendor/proc-macro-crate/Cargo.toml
new file mode 100644
index 0000000..03f0bfe
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "proc-macro-crate"
+version = "1.1.0"
+authors = ["Bastian Köcher <git@kchr.de>"]
+description = "Replacement for crate (macro_rules keyword) in proc-macros\n"
+documentation = "https://docs.rs/proc-macro-crate"
+readme = "./README.md"
+keywords = ["macro-rules", "crate", "macro", "proc-macro"]
+categories = ["development-tools::procedural-macro-helpers"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/bkchr/proc-macro-crate"
+[dependencies.thiserror]
+version = "1.0.24"
+
+[dependencies.toml]
+version = "0.5.2"
+[dev-dependencies.proc-macro2]
+version = "1.0.18"
+
+[dev-dependencies.quote]
+version = "1.0.7"
+
+[dev-dependencies.syn]
+version = "1.0.33"
diff --git a/rust/vendor/proc-macro-crate/LICENSE-APACHE b/rust/vendor/proc-macro-crate/LICENSE-APACHE
new file mode 100644
index 0000000..c98d27d
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ https://www.apache.org/licenses/LICENSE-2.0
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ https://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/rust/vendor/proc-macro-crate/LICENSE-MIT b/rust/vendor/proc-macro-crate/LICENSE-MIT
new file mode 100644
index 0000000..31aa793
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/rust/vendor/proc-macro-crate/README.md b/rust/vendor/proc-macro-crate/README.md
new file mode 100644
index 0000000..bfda755
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/README.md
@@ -0,0 +1,58 @@
+# proc-macro-crate
+
+
+[![](https://docs.rs/proc-macro-crate/badge.svg)](https://docs.rs/proc-macro-crate/) [![](https://img.shields.io/crates/v/proc-macro-crate.svg)](https://crates.io/crates/proc-macro-crate) [![](https://img.shields.io/crates/d/proc-macro-crate.png)](https://crates.io/crates/proc-macro-crate) [![Build Status](https://travis-ci.org/bkchr/proc-macro-crate.png?branch=master)](https://travis-ci.org/bkchr/proc-macro-crate)
+
+Providing support for `$crate` in procedural macros.
+
+* [Introduction](#introduction)
+* [Example](#example)
+* [License](#license)
+
+### Introduction
+
+In `macro_rules!` `$crate` is used to get the path of the crate where a macro is declared in. In
+procedural macros there is currently no easy way to get this path. A common hack is to import the
+desired crate with a know name and use this. However, with rust edition 2018 and dropping
+`extern crate` declarations from `lib.rs`, people start to rename crates in `Cargo.toml` directly.
+However, this breaks importing the crate, as the proc-macro developer does not know the renamed
+name of the crate that should be imported.
+
+This crate provides a way to get the name of a crate, even if it renamed in `Cargo.toml`. For this
+purpose a single function `crate_name` is provided. This function needs to be called in the context
+of a proc-macro with the name of the desired crate. `CARGO_MANIFEST_DIR` will be used to find the
+current active `Cargo.toml` and this `Cargo.toml` is searched for the desired crate.
+
+### Example
+
+```rust
+use quote::quote;
+use syn::Ident;
+use proc_macro2::Span;
+use proc_macro_crate::{crate_name, FoundCrate};
+
+fn import_my_crate() {
+ let found_crate = crate_name("my-crate").expect("my-crate is present in `Cargo.toml`");
+
+ match found_crate {
+ FoundCrate::Itself => quote!( crate::Something ),
+ FoundCrate::Name(name) => {
+ let ident = Ident::new(&name, Span::call_site());
+ quote!( #ident::Something )
+ }
+ };
+}
+
+```
+
+### License
+
+Licensed under either of
+
+ * [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+ * [MIT license](http://opensource.org/licenses/MIT)
+
+at your option.
+
+License: Apache-2.0/MIT
diff --git a/rust/vendor/proc-macro-crate/src/lib.rs b/rust/vendor/proc-macro-crate/src/lib.rs
new file mode 100644
index 0000000..09a2dd6
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/src/lib.rs
@@ -0,0 +1,335 @@
+/*!
+
+[![](https://docs.rs/proc-macro-crate/badge.svg)](https://docs.rs/proc-macro-crate/) [![](https://img.shields.io/crates/v/proc-macro-crate.svg)](https://crates.io/crates/proc-macro-crate) [![](https://img.shields.io/crates/d/proc-macro-crate.png)](https://crates.io/crates/proc-macro-crate) [![Build Status](https://travis-ci.org/bkchr/proc-macro-crate.png?branch=master)](https://travis-ci.org/bkchr/proc-macro-crate)
+
+Providing support for `$crate` in procedural macros.
+
+* [Introduction](#introduction)
+* [Example](#example)
+* [License](#license)
+
+## Introduction
+
+In `macro_rules!` `$crate` is used to get the path of the crate where a macro is declared in. In
+procedural macros there is currently no easy way to get this path. A common hack is to import the
+desired crate with a know name and use this. However, with rust edition 2018 and dropping
+`extern crate` declarations from `lib.rs`, people start to rename crates in `Cargo.toml` directly.
+However, this breaks importing the crate, as the proc-macro developer does not know the renamed
+name of the crate that should be imported.
+
+This crate provides a way to get the name of a crate, even if it renamed in `Cargo.toml`. For this
+purpose a single function `crate_name` is provided. This function needs to be called in the context
+of a proc-macro with the name of the desired crate. `CARGO_MANIFEST_DIR` will be used to find the
+current active `Cargo.toml` and this `Cargo.toml` is searched for the desired crate.
+
+## Example
+
+```
+use quote::quote;
+use syn::Ident;
+use proc_macro2::Span;
+use proc_macro_crate::{crate_name, FoundCrate};
+
+fn import_my_crate() {
+ let found_crate = crate_name("my-crate").expect("my-crate is present in `Cargo.toml`");
+
+ match found_crate {
+ FoundCrate::Itself => quote!( crate::Something ),
+ FoundCrate::Name(name) => {
+ let ident = Ident::new(&name, Span::call_site());
+ quote!( #ident::Something )
+ }
+ };
+}
+
+# fn main() {}
+```
+
+## License
+
+Licensed under either of
+
+ * [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+ * [MIT license](http://opensource.org/licenses/MIT)
+
+at your option.
+*/
+
+use std::{
+ collections::HashMap,
+ env,
+ fs::File,
+ io::{self, Read},
+ path::{Path, PathBuf},
+};
+
+use toml::{self, value::Table};
+
+type CargoToml = HashMap<String, toml::Value>;
+
+/// Error type used by this crate.
+#[derive(Debug, thiserror::Error)]
+pub enum Error {
+ #[error("Could not find `Cargo.toml` in manifest dir: `{0}`.")]
+ NotFound(PathBuf),
+ #[error("`CARGO_MANIFEST_DIR` env variable not set.")]
+ CargoManifestDirNotSet,
+ #[error("Could not read `{path}`.")]
+ CouldNotRead { path: PathBuf, source: io::Error },
+ #[error("Invalid toml file.")]
+ InvalidToml { source: toml::de::Error },
+ #[error("Could not find `{crate_name}` in `dependencies` or `dev-dependencies` in `{path}`!")]
+ CrateNotFound { crate_name: String, path: PathBuf },
+}
+
+/// The crate as found by [`crate_name`].
+#[derive(Debug, PartialEq, Clone, Eq)]
+pub enum FoundCrate {
+ /// The searched crate is this crate itself.
+ Itself,
+ /// The searched crate was found with this name.
+ Name(String),
+}
+
+/// Find the crate name for the given `orig_name` in the current `Cargo.toml`.
+///
+/// `orig_name` should be the original name of the searched crate.
+///
+/// The current `Cargo.toml` is determined by taking `CARGO_MANIFEST_DIR/Cargo.toml`.
+///
+/// # Returns
+///
+/// - `Ok(orig_name)` if the crate was found, but not renamed in the `Cargo.toml`.
+/// - `Ok(RENAMED)` if the crate was found, but is renamed in the `Cargo.toml`. `RENAMED` will be
+/// the renamed name.
+/// - `Err` if an error occurred.
+///
+/// The returned crate name is sanitized in such a way that it is a valid rust identifier. Thus,
+/// it is ready to be used in `extern crate` as identifier.
+pub fn crate_name(orig_name: &str) -> Result<FoundCrate, Error> {
+ let manifest_dir =
+ PathBuf::from(env::var("CARGO_MANIFEST_DIR").map_err(|_| Error::CargoManifestDirNotSet)?);
+
+ let cargo_toml_path = manifest_dir.join("Cargo.toml");
+
+ if !cargo_toml_path.exists() {
+ return Err(Error::NotFound(manifest_dir.into()));
+ }
+
+ let cargo_toml = open_cargo_toml(&cargo_toml_path)?;
+
+ extract_crate_name(orig_name, cargo_toml, &cargo_toml_path)
+}
+
+/// Make sure that the given crate name is a valid rust identifier.
+fn sanitize_crate_name<S: AsRef<str>>(name: S) -> String {
+ name.as_ref().replace("-", "_")
+}
+
+/// Open the given `Cargo.toml` and parse it into a hashmap.
+fn open_cargo_toml(path: &Path) -> Result<CargoToml, Error> {
+ let mut content = String::new();
+ File::open(path)
+ .map_err(|e| Error::CouldNotRead {
+ source: e,
+ path: path.into(),
+ })?
+ .read_to_string(&mut content)
+ .map_err(|e| Error::CouldNotRead {
+ source: e,
+ path: path.into(),
+ })?;
+ toml::from_str(&content).map_err(|e| Error::InvalidToml { source: e })
+}
+
+/// Extract the crate name for the given `orig_name` from the given `Cargo.toml` by checking the
+/// `dependencies` and `dev-dependencies`.
+///
+/// Returns `Ok(orig_name)` if the crate is not renamed in the `Cargo.toml` or otherwise
+/// the renamed identifier.
+fn extract_crate_name(
+ orig_name: &str,
+ mut cargo_toml: CargoToml,
+ cargo_toml_path: &Path,
+) -> Result<FoundCrate, Error> {
+ if let Some(toml::Value::Table(t)) = cargo_toml.get("package") {
+ if let Some(toml::Value::String(s)) = t.get("name") {
+ if s == orig_name {
+ if std::env::var_os("CARGO_TARGET_TMPDIR").is_none() {
+ // We're running for a library/binary crate
+ return Ok(FoundCrate::Itself);
+ } else {
+ // We're running for an integration test
+ return Ok(FoundCrate::Name(sanitize_crate_name(orig_name)));
+ }
+ }
+ }
+ }
+
+ if let Some(name) = ["dependencies", "dev-dependencies"]
+ .iter()
+ .find_map(|k| search_crate_at_key(k, orig_name, &mut cargo_toml))
+ {
+ return Ok(FoundCrate::Name(sanitize_crate_name(name)));
+ }
+
+ // Start searching `target.xy.dependencies`
+ if let Some(name) = cargo_toml
+ .remove("target")
+ .and_then(|t| t.try_into::<Table>().ok())
+ .and_then(|t| {
+ t.values()
+ .filter_map(|v| v.as_table())
+ .filter_map(|t| t.get("dependencies").and_then(|t| t.as_table()))
+ .find_map(|t| extract_crate_name_from_deps(orig_name, t.clone()))
+ })
+ {
+ return Ok(FoundCrate::Name(sanitize_crate_name(name)));
+ }
+
+ Err(Error::CrateNotFound {
+ crate_name: orig_name.into(),
+ path: cargo_toml_path.into(),
+ })
+}
+
+/// Search the `orig_name` crate at the given `key` in `cargo_toml`.
+fn search_crate_at_key(key: &str, orig_name: &str, cargo_toml: &mut CargoToml) -> Option<String> {
+ cargo_toml
+ .remove(key)
+ .and_then(|v| v.try_into::<Table>().ok())
+ .and_then(|t| extract_crate_name_from_deps(orig_name, t))
+}
+
+/// Extract the crate name from the given dependencies.
+///
+/// Returns `Some(orig_name)` if the crate is not renamed in the `Cargo.toml` or otherwise
+/// the renamed identifier.
+fn extract_crate_name_from_deps(orig_name: &str, deps: Table) -> Option<String> {
+ for (key, value) in deps.into_iter() {
+ let renamed = value
+ .try_into::<Table>()
+ .ok()
+ .and_then(|t| t.get("package").cloned())
+ .map(|t| t.as_str() == Some(orig_name))
+ .unwrap_or(false);
+
+ if key == orig_name || renamed {
+ return Some(key.clone());
+ }
+ }
+
+ None
+}
+
+#[cfg(test)]
+mod tests {
+ use super::*;
+
+ macro_rules! create_test {
+ (
+ $name:ident,
+ $cargo_toml:expr,
+ $( $result:tt )*
+ ) => {
+ #[test]
+ fn $name() {
+ let cargo_toml = toml::from_str($cargo_toml).expect("Parses `Cargo.toml`");
+ let path = PathBuf::from("test-path");
+
+ match extract_crate_name("my_crate", cargo_toml, &path) {
+ $( $result )* => (),
+ o => panic!("Invalid result: {:?}", o),
+ }
+ }
+ };
+ }
+
+ create_test! {
+ deps_with_crate,
+ r#"
+ [dependencies]
+ my_crate = "0.1"
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "my_crate"
+ }
+
+ create_test! {
+ dev_deps_with_crate,
+ r#"
+ [dev-dependencies]
+ my_crate = "0.1"
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "my_crate"
+ }
+
+ create_test! {
+ deps_with_crate_renamed,
+ r#"
+ [dependencies]
+ cool = { package = "my_crate", version = "0.1" }
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "cool"
+ }
+
+ create_test! {
+ deps_with_crate_renamed_second,
+ r#"
+ [dependencies.cool]
+ package = "my_crate"
+ version = "0.1"
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "cool"
+ }
+
+ create_test! {
+ deps_empty,
+ r#"
+ [dependencies]
+ "#,
+ Err(Error::CrateNotFound {
+ crate_name,
+ path,
+ }) if crate_name == "my_crate" && path.display().to_string() == "test-path"
+ }
+
+ create_test! {
+ crate_not_found,
+ r#"
+ [dependencies]
+ serde = "1.0"
+ "#,
+ Err(Error::CrateNotFound {
+ crate_name,
+ path,
+ }) if crate_name == "my_crate" && path.display().to_string() == "test-path"
+ }
+
+ create_test! {
+ target_dependency,
+ r#"
+ [target.'cfg(target_os="android")'.dependencies]
+ my_crate = "0.1"
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "my_crate"
+ }
+
+ create_test! {
+ target_dependency2,
+ r#"
+ [target.x86_64-pc-windows-gnu.dependencies]
+ my_crate = "0.1"
+ "#,
+ Ok(FoundCrate::Name(name)) if name == "my_crate"
+ }
+
+ create_test! {
+ own_crate,
+ r#"
+ [package]
+ name = "my_crate"
+ "#,
+ Ok(FoundCrate::Itself)
+ }
+}