summaryrefslogtreecommitdiffstats
path: root/rust/vendor/ctr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/ctr/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/rust/vendor/ctr/Cargo.toml b/rust/vendor/ctr/Cargo.toml
new file mode 100644
index 0000000..701d540
--- /dev/null
+++ b/rust/vendor/ctr/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "ctr"
+version = "0.8.0"
+authors = ["RustCrypto Developers"]
+description = "CTR block mode of operation"
+documentation = "https://docs.rs/ctr"
+readme = "README.md"
+keywords = ["crypto", "stream-cipher", "trait"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/stream-ciphers"
+[dependencies.cipher]
+version = "0.3"
+[dev-dependencies.aes]
+version = "0.7"
+features = ["force-soft"]
+
+[dev-dependencies.cipher]
+version = "0.3"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2"
+
+[dev-dependencies.kuznyechik]
+version = "0.7"
+
+[dev-dependencies.magma]
+version = "0.7"