summaryrefslogtreecommitdiffstats
path: root/rust/vendor/ghash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/ghash/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/rust/vendor/ghash/Cargo.toml b/rust/vendor/ghash/Cargo.toml
new file mode 100644
index 0000000..e82ec25
--- /dev/null
+++ b/rust/vendor/ghash/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "ghash"
+version = "0.4.4"
+authors = ["RustCrypto Developers"]
+description = "Universal hash over GF(2^128) useful for constructing a Message Authentication Code (MAC),\nas in the AES-GCM authenticated encryption cipher.\n"
+documentation = "https://docs.rs/ghash"
+readme = "README.md"
+keywords = ["aes-gcm", "crypto", "universal-hashing"]
+categories = ["cryptography", "no-std"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/universal-hashes"
+[dependencies.opaque-debug]
+version = "0.3"
+
+[dependencies.polyval]
+version = "0.5.1"
+
+[dependencies.zeroize]
+version = ">=1, <1.4"
+optional = true
+default-features = false
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[features]
+armv8 = ["polyval/armv8"]
+force-soft = ["polyval/force-soft"]
+std = ["polyval/std"]