summaryrefslogtreecommitdiffstats
path: root/rust/vendor/hmac/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/hmac/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/rust/vendor/hmac/Cargo.toml b/rust/vendor/hmac/Cargo.toml
new file mode 100644
index 0000000..ca1c001
--- /dev/null
+++ b/rust/vendor/hmac/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "hmac"
+version = "0.12.1"
+authors = ["RustCrypto Developers"]
+description = "Generic implementation of Hash-based Message Authentication Code (HMAC)"
+documentation = "https://docs.rs/hmac"
+readme = "README.md"
+keywords = ["crypto", "mac", "hmac", "digest"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/MACs"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.digest]
+version = "0.10.3"
+features = ["mac"]
+[dev-dependencies.digest]
+version = "0.10"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2.2"
+
+[dev-dependencies.md-5]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.sha-1]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.sha2]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.streebog]
+version = "0.10"
+default-features = false
+
+[features]
+reset = []
+std = ["digest/std"]