summaryrefslogtreecommitdiffstats
path: root/rust/vendor/md-5/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/md-5/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/rust/vendor/md-5/Cargo.toml b/rust/vendor/md-5/Cargo.toml
new file mode 100644
index 0000000..40f618e
--- /dev/null
+++ b/rust/vendor/md-5/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "md-5"
+version = "0.10.6"
+authors = ["RustCrypto Developers"]
+description = "MD5 hash function"
+documentation = "https://docs.rs/md-5"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "md5",
+ "hash",
+ "digest",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+
+[lib]
+name = "md5"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.digest]
+version = "0.10.7"
+
+[dev-dependencies.digest]
+version = "0.10.7"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2.2"
+
+[features]
+asm = ["md5-asm"]
+default = ["std"]
+force-soft = []
+loongarch64_asm = []
+oid = ["digest/oid"]
+std = ["digest/std"]
+
+[target."cfg(any(target_arch = \"x86\", target_arch = \"x86_64\"))".dependencies.md5-asm]
+version = "0.5"
+optional = true