summaryrefslogtreecommitdiffstats
path: root/rust/vendor/num-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/num-derive/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/rust/vendor/num-derive/Cargo.toml b/rust/vendor/num-derive/Cargo.toml
new file mode 100644
index 0000000..f7c68ad
--- /dev/null
+++ b/rust/vendor/num-derive/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "num-derive"
+version = "0.2.5"
+authors = ["The Rust Project Developers"]
+build = "build.rs"
+exclude = ["/ci/*", "/.travis.yml", "/bors.toml"]
+description = "Numeric syntax extensions"
+homepage = "https://github.com/rust-num/num-derive"
+documentation = "https://docs.rs/num-derive"
+readme = "README.md"
+keywords = ["mathematics", "numerics"]
+categories = ["science"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-num/num-derive"
+
+[lib]
+name = "num_derive"
+test = false
+proc-macro = true
+[dependencies.proc-macro2]
+version = "0.4.2"
+
+[dependencies.quote]
+version = "0.6"
+
+[dependencies.syn]
+version = "0.15"
+[dev-dependencies.num]
+version = "0.2"
+
+[dev-dependencies.num-traits]
+version = "0.2"
+
+[features]
+full-syntax = ["syn/full"]