summaryrefslogtreecommitdiffstats
path: root/rust/vendor/sawp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/sawp/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/rust/vendor/sawp/Cargo.toml b/rust/vendor/sawp/Cargo.toml
new file mode 100644
index 0000000..fa2b088
--- /dev/null
+++ b/rust/vendor/sawp/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.58.1"
+name = "sawp"
+version = "0.12.1"
+authors = ["Canadian Centre for Cyber Security <sa-sawp@cyber.gc.ca>"]
+include = [
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+ "src/**/*.rs",
+]
+description = "Security Aware Wire Protocol parsing library"
+homepage = "https://github.com/CybercentreCanada/sawp"
+readme = "README.md"
+keywords = [
+ "parser",
+ "streaming",
+ "protocols",
+ "network",
+ "api",
+]
+categories = [
+ "parsing",
+ "network-programming",
+]
+license-file = "LICENSE"
+repository = "https://github.com/CybercentreCanada/sawp"
+
+[lib]
+crate-type = [
+ "staticlib",
+ "rlib",
+ "cdylib",
+]
+bench = false
+
+[[bench]]
+name = "modbus"
+path = "benches/modbus.rs"
+harness = false
+
+[dependencies.nom]
+version = "7.1.1"
+
+[dependencies.sawp-ffi]
+version = "^0.12.1"
+optional = true
+
+[dev-dependencies.clap]
+version = "~2.33"
+
+[dev-dependencies.criterion]
+version = "=0.3.4"
+
+[dev-dependencies.csv]
+version = "=1.1.6"
+
+[dev-dependencies.rayon]
+version = "=1.6.1"
+
+[dev-dependencies.rayon-core]
+version = "=1.10.2"
+
+[build-dependencies.cbindgen]
+version = "0.15"
+optional = true
+
+[features]
+ffi = [
+ "cbindgen",
+ "sawp-ffi",
+]
+verbose = []