summaryrefslogtreecommitdiffstats
path: root/rust/vendor/sha2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--rust/vendor/sha2/Cargo.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/rust/vendor/sha2/Cargo.toml b/rust/vendor/sha2/Cargo.toml
new file mode 100644
index 0000000..0a9655c
--- /dev/null
+++ b/rust/vendor/sha2/Cargo.toml
@@ -0,0 +1,71 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sha2"
+version = "0.10.8"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of the SHA-2 hash function family
+including SHA-224, SHA-256, SHA-384, and SHA-512.
+"""
+documentation = "https://docs.rs/sha2"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "sha2",
+ "hash",
+ "digest",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.digest]
+version = "0.10.7"
+
+[dev-dependencies.digest]
+version = "0.10.7"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2.2"
+
+[features]
+asm = ["sha2-asm"]
+asm-aarch64 = ["asm"]
+compress = []
+default = ["std"]
+force-soft = []
+loongarch64_asm = []
+oid = ["digest/oid"]
+std = ["digest/std"]
+
+[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.cpufeatures]
+version = "0.2"
+
+[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.sha2-asm]
+version = "0.6.1"
+optional = true