summaryrefslogtreecommitdiffstats
path: root/src/autoconf.h.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/autoconf.h.in')
-rw-r--r--src/autoconf.h.in855
1 files changed, 855 insertions, 0 deletions
diff --git a/src/autoconf.h.in b/src/autoconf.h.in
new file mode 100644
index 0000000..58ee1a4
--- /dev/null
+++ b/src/autoconf.h.in
@@ -0,0 +1,855 @@
+/* src/autoconf.h.in. Generated from configure.ac by autoheader. */
+
+/* Disable all use of random functions */
+#undef AFLFUZZ_NO_RANDOM
+
+/* Enable AFL PERSISTENT_MODE */
+#undef AFLFUZZ_PERSISTENT_MODE
+
+/* Intel Hyperscan support enabled */
+#undef BUILD_HYPERSCAN
+
+/* Unix socket support enabled */
+#undef BUILD_UNIX_SOCKET
+
+/* Building flow capture bypass code */
+#undef CAPTURE_OFFLOAD
+
+/* Building flow bypass manager code */
+#undef CAPTURE_OFFLOAD_MANAGER
+
+/* L1 cache line size */
+#undef CLS
+
+/* Our CONFIG_DIR */
+#undef CONFIG_DIR
+
+/* Our DATA_DIR */
+#undef DATA_DIR
+
+/* Enable debug output */
+#undef DEBUG
+
+/* Enable (debug) validation code output */
+#undef DEBUG_VALIDATION
+
+/* Fuzz targets are enabled */
+#undef FUZZ
+
+/* AF_PACKET support is available */
+#undef HAVE_AF_PACKET
+
+/* AF_XDP support is available */
+#undef HAVE_AF_XDP
+
+/* Define to 1 if you have the `alarm' function. */
+#undef HAVE_ALARM
+
+/* Define to 1 if you have the <arpa/inet.h> header file. */
+#undef HAVE_ARPA_INET_H
+
+/* Define to 1 if you have the <assert.h> header file. */
+#undef HAVE_ASSERT_H
+
+/* Define to 1 if you have the `atexit' function. */
+#undef HAVE_ATEXIT
+
+/* Define to 1 if you have the <bpf/libbpf.h> header file. */
+#undef HAVE_BPF_LIBBPF_H
+
+/* Define to 1 if you have the `bpf_program__section_name' function. */
+#undef HAVE_BPF_PROGRAM__SECTION_NAME
+
+/* Define to 1 if you have the `bpf_program__set_type' function. */
+#undef HAVE_BPF_PROGRAM__SET_TYPE
+
+/* Define to 1 if you have the `bpf_xdp_attach' function. */
+#undef HAVE_BPF_XDP_ATTACH
+
+/* Define to 1 if you have the `bpf_xdp_query_id' function. */
+#undef HAVE_BPF_XDP_QUERY_ID
+
+/* Define to 1 if you have the `clock_gettime' function. */
+#undef HAVE_CLOCK_GETTIME
+
+/* Define to 1 if you have the <ctype.h> header file. */
+#undef HAVE_CTYPE_H
+
+/* (Endace DAG card support enabled) */
+#undef HAVE_DAG
+
+/* Define to 1 if you have the declaration of `tzname', and to 0 if you don't.
+ */
+#undef HAVE_DECL_TZNAME
+
+/* Detection is disabled */
+#undef HAVE_DETECT_DISABLED
+
+/* Define to 1 if you have the <dirent.h> header file. */
+#undef HAVE_DIRENT_H
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#undef HAVE_DLFCN_H
+
+/* (DPDK support enabled) */
+#undef HAVE_DPDK
+
+/* (DPDK Bond PMD support enabled) */
+#undef HAVE_DPDK_BOND
+
+/* Define to 1 if you have the `dup2' function. */
+#undef HAVE_DUP2
+
+/* Define to 1 if you have the `endgrent' function. */
+#undef HAVE_ENDGRENT
+
+/* Define to 1 if you have the `endpwent' function. */
+#undef HAVE_ENDPWENT
+
+/* Define to 1 if you have the <errno.h> header file. */
+#undef HAVE_ERRNO_H
+
+/* Define to 1 if you have the <fcntl.h> header file. */
+#undef HAVE_FCNTL_H
+
+/* Define to 1 if you have the <fnmatch.h> header file. */
+#undef HAVE_FNMATCH_H
+
+/* Define to 1 if you have the `fork' function. */
+#undef HAVE_FORK
+
+/* Define to 1 if you have the `fwrite_unlocked' function. */
+#undef HAVE_FWRITE_UNLOCKED
+
+/* libmaxminddb available */
+#undef HAVE_GEOIP
+
+/* Define to 1 if you have the `gethostname' function. */
+#undef HAVE_GETHOSTNAME
+
+/* Define to 1 if you have the <getopt.h> header file. */
+#undef HAVE_GETOPT_H
+
+/* Define to 1 if you have the `getpagesize' function. */
+#undef HAVE_GETPAGESIZE
+
+/* Use getrandom */
+#undef HAVE_GETRANDOM
+
+/* Define to 1 if you have the `gettimeofday' function. */
+#undef HAVE_GETTIMEOFDAY
+
+/* Define to 1 if you have the <glob.h> header file. */
+#undef HAVE_GLOB_H
+
+/* Define to 1 if you have the <grp.h> header file. */
+#undef HAVE_GRP_H
+
+/* Define to 1 if you have the `hs_valid_platform' function. */
+#undef HAVE_HS_VALID_PLATFORM
+
+/* Assuming htp_config_set_compression_bomb_limit function in bundled libhtp
+ */
+#undef HAVE_HTP_CONFIG_SET_COMPRESSION_BOMB_LIMIT
+
+/* Assuming htp_config_set_compression_time_limit function in bundled libhtp
+ */
+#undef HAVE_HTP_CONFIG_SET_COMPRESSION_TIME_LIMIT
+
+/* Assuming htp_config_set_lzma_layers function in bundled libhtp */
+#undef HAVE_HTP_CONFIG_SET_LZMA_LAYERS
+
+/* Assuming htp_config_set_lzma_memlimit function in bundled libhtp */
+#undef HAVE_HTP_CONFIG_SET_LZMA_MEMLIMIT
+
+/* Assuming htp_config_set_max_tx function in bundled libhtp */
+#undef HAVE_HTP_CONFIG_SET_MAX_TX
+
+/* Assuming htp_config_set_response_decompression_layer_limit function in
+ bundled libhtp */
+#undef HAVE_HTP_CONFIG_SET_RESPONSE_DECOMPRESSION_LAYER_LIMIT
+
+/* Assuming htp_decode_query_inplace function in bundled libhtp */
+#undef HAVE_HTP_DECODE_QUERY_INPLACE
+
+/* Found usable htp_config_set_path_decode_u_encoding function in libhtp */
+#undef HAVE_HTP_SET_PATH_DECODE_U_ENCODING
+
+/* Assuming htp_tx_get_response_headers_raw function in bundled libhtp */
+#undef HAVE_HTP_TX_GET_RESPONSE_HEADERS_RAW
+
+/* Assuming htp_config_register_request_uri_normalize function in bundled
+ libhtp */
+#undef HAVE_HTP_URI_NORMALIZE_HOOK
+
+/* Hardware timestamping support is available */
+#undef HAVE_HW_TIMESTAMPING
+
+/* Define to 1 if you have the `inet_ntoa' function. */
+#undef HAVE_INET_NTOA
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#undef HAVE_INTTYPES_H
+
+/* Define to 1 if you have the `bpf' library (-lbpf). */
+#undef HAVE_LIBBPF
+
+/* Libpcap-ng support */
+#undef HAVE_LIBCAP_NG
+
+/* Define to 1 if you have the `dag' library (-ldag). */
+#undef HAVE_LIBDAG
+
+/* Define to 1 if you have the `elf' library (-lelf). */
+#undef HAVE_LIBELF
+
+/* libevent available */
+#undef HAVE_LIBEVENT
+
+/* Define to 1 if you have the `event_pthreads' library (-levent_pthreads). */
+#undef HAVE_LIBEVENT_PTHREADS
+
+/* Define to 1 if you have the <libgen.h> header file. */
+#undef HAVE_LIBGEN_H
+
+/* libhiredis available */
+#undef HAVE_LIBHIREDIS
+
+/* Define to 1 if you have the `hs' library (-lhs). */
+#undef HAVE_LIBHS
+
+/* Define to 1 if you have the `htp' library (-lhtp). */
+#undef HAVE_LIBHTP
+
+/* Define to 1 if you have the `iconv' library (-liconv). */
+#undef HAVE_LIBICONV
+
+/* Define to 1 if you have the `jansson' library (-ljansson). */
+#undef HAVE_LIBJANSSON
+
+/* Define to 1 if you have the `lua' library (-llua). */
+#undef HAVE_LIBLUA
+
+/* Define to 1 if you have the `luajit-5.1' library (-lluajit-5.1). */
+#undef HAVE_LIBLUAJIT_5_1
+
+/* Define to 1 if you have the `lz4' library (-llz4). */
+#undef HAVE_LIBLZ4
+
+/* Define to 1 if you have the `magic' library (-lmagic). */
+#undef HAVE_LIBMAGIC
+
+/* Define to 1 if you have the `maxminddb' library (-lmaxminddb). */
+#undef HAVE_LIBMAXMINDDB
+
+/* Define to 1 if you have the `net' library (-lnet). */
+#undef HAVE_LIBNET
+
+/* (libnet 1.1 available) */
+#undef HAVE_LIBNET11
+
+/* Define to 1 if you have the `netfilter_log' library (-lnetfilter_log). */
+#undef HAVE_LIBNETFILTER_LOG
+
+/* Define to 1 if you have the `netfilter_queue' library (-lnetfilter_queue).
+ */
+#undef HAVE_LIBNETFILTER_QUEUE
+
+/* (libnet_have_capabilities_patch) */
+#undef HAVE_LIBNET_CAPABILITIES
+
+/* (libnet_build_icmpv6_unreach available) */
+#undef HAVE_LIBNET_ICMPV6_UNREACH
+
+/* libnet_init takes const argument */
+#undef HAVE_LIBNET_INIT_CONST
+
+/* Define to 1 if you have the `nfnetlink' library (-lnfnetlink). */
+#undef HAVE_LIBNFNETLINK
+
+/* Define to 1 if you have the `numa' library (-lnuma). */
+#undef HAVE_LIBNUMA
+
+/* Define to 1 if you have the `pcap' library (-lpcap). */
+#undef HAVE_LIBPCAP
+
+/* Define to 1 if you have the `pcre2-8' library (-lpcre2-8). */
+#undef HAVE_LIBPCRE2_8
+
+/* Define to 1 if you have the `pfring' library (-lpfring). */
+#undef HAVE_LIBPFRING
+
+/* Define to 1 if you have the `pthread' library (-lpthread). */
+#undef HAVE_LIBPTHREAD
+
+/* Define to 1 if you have the `systemd' library (-lsystemd). */
+#undef HAVE_LIBSYSTEMD
+
+/* Define to 1 if you have the `unwind' library (-lunwind). */
+#undef HAVE_LIBUNWIND
+
+/* Define to 1 if you have the `WinDivert' library (-lWinDivert). */
+#undef HAVE_LIBWINDIVERT
+
+/* Define to 1 if you have the `wpcap' library (-lwpcap). */
+#undef HAVE_LIBWPCAP
+
+/* Define to 1 if you have the `xdp' library (-lxdp). */
+#undef HAVE_LIBXDP
+
+/* Define to 1 if you have the `yaml' library (-lyaml). */
+#undef HAVE_LIBYAML
+
+/* Define to 1 if you have the `z' library (-lz). */
+#undef HAVE_LIBZ
+
+/* Define to 1 if you have the <limits.h> header file. */
+#undef HAVE_LIMITS_H
+
+/* Define to 1 if you have the <linux/ethtool.h> header file. */
+#undef HAVE_LINUX_ETHTOOL_H
+
+/* Define to 1 if you have the <linux/filter.h> header file. */
+#undef HAVE_LINUX_FILTER_H
+
+/* Define to 1 if you have the <linux/if_arp.h> header file. */
+#undef HAVE_LINUX_IF_ARP_H
+
+/* Define to 1 if you have the <linux/if_ether.h> header file. */
+#undef HAVE_LINUX_IF_ETHER_H
+
+/* Define to 1 if you have the <linux/if_packet.h> header file. */
+#undef HAVE_LINUX_IF_PACKET_H
+
+/* Define to 1 if you have the <linux/landlock.h> header file. */
+#undef HAVE_LINUX_LANDLOCK_H
+
+/* Define to 1 if you have the <linux/sockios.h> header file. */
+#undef HAVE_LINUX_SOCKIOS_H
+
+/* Define to 1 if you have the <locale.h> header file. */
+#undef HAVE_LOCALE_H
+
+/* Define to 1 if you have the `localtime_r' function. */
+#undef HAVE_LOCALTIME_R
+
+/* lua support available */
+#undef HAVE_LUA
+
+/* libluajit available */
+#undef HAVE_LUAJIT
+
+/* Define to 1 if you have the <mach/mach.h> header file. */
+#undef HAVE_MACH_MACH_H
+
+/* (Libmagic for file handling) */
+#undef HAVE_MAGIC
+
+/* Define to 1 if your system has a GNU libc compatible `malloc' function, and
+ to 0 otherwise. */
+#undef HAVE_MALLOC
+
+/* Define to 1 if you have the <math.h> header file. */
+#undef HAVE_MATH_H
+
+/* Define to 1 if you have the `memchr' function. */
+#undef HAVE_MEMCHR
+
+/* Define to 1 if you have the `memmem' function. */
+#undef HAVE_MEMMEM
+
+/* Define to 1 if you have the `memmove' function. */
+#undef HAVE_MEMMOVE
+
+/* Define to 1 if you have the `memrchr' function. */
+#undef HAVE_MEMRCHR
+
+/* Define to 1 if you have the `memset' function. */
+#undef HAVE_MEMSET
+
+/* Define to 1 if you have a working `mmap' system call. */
+#undef HAVE_MMAP
+
+/* Define to 1 if you have the `munmap' function. */
+#undef HAVE_MUNMAP
+
+/* (Napatech capture card support) */
+#undef HAVE_NAPATECH
+
+/* Define to 1 if you have the <netdb.h> header file. */
+#undef HAVE_NETDB_H
+
+/* Define to 1 if you have the <netinet/in.h> header file. */
+#undef HAVE_NETINET_IN_H
+
+/* (NETMAP support enabled) */
+#undef HAVE_NETMAP
+
+/* (NETMAP API v14 support enabled) */
+#undef HAVE_NETMAP_V14
+
+/* (ethernet.h) */
+#undef HAVE_NET_ETHERNET_H
+
+/* Define to 1 if you have the <net/if.h> header file. */
+#undef HAVE_NET_IF_H
+
+/* nflog available */
+#undef HAVE_NFLOG
+
+/* Found queue max length support in netfilter_queue */
+#undef HAVE_NFQ_MAXLEN
+
+/* Found nfq_set_queue_flags function in netfilter_queue */
+#undef HAVE_NFQ_SET_QUEUE_FLAGS
+
+/* Found nfq_set_verdict2 function in netfilter_queue */
+#undef HAVE_NFQ_SET_VERDICT2
+
+/* Found nfq_set_verdict_batch function in netfilter_queue */
+#undef HAVE_NFQ_SET_VERDICT_BATCH
+
+/* mkdir is not POSIX compliant: single arg */
+#undef HAVE_NON_POSIX_MKDIR
+
+/* Recent ebpf fanout support is available */
+#undef HAVE_PACKET_EBPF
+
+/* Recent packet fanout support is available */
+#undef HAVE_PACKET_FANOUT
+
+/* XDP support is available */
+#undef HAVE_PACKET_XDP
+
+/* Define to 1 if you have the <pcap/bpf.h> header file. */
+#undef HAVE_PCAP_BPF_H
+
+/* Define to 1 if you have the <pcap.h> header file. */
+#undef HAVE_PCAP_H
+
+/* Define to 1 if you have the <pcap/pcap.h> header file. */
+#undef HAVE_PCAP_PCAP_H
+
+/* (libpcap has pcap_set_buffer_size function) */
+#undef HAVE_PCAP_SET_BUFF
+
+/* (PF_RING support enabled) */
+#undef HAVE_PFRING
+
+/* PF_RING bypass support enabled */
+#undef HAVE_PF_RING_FLOW_OFFLOAD
+
+/* Plugin support */
+#undef HAVE_PLUGINS
+
+/* Define to 1 if you have the <poll.h> header file. */
+#undef HAVE_POLL_H
+
+/* Define to 1 if you have the `pthread_getattr_np' function. */
+#undef HAVE_PTHREAD_GETATTR_NP
+
+/* Define to 1 if you have the `pthread_spin_unlock' function. */
+#undef HAVE_PTHREAD_SPIN_UNLOCK
+
+/* Define to 1 if the system has the type `ptrdiff_t'. */
+#undef HAVE_PTRDIFF_T
+
+/* Define to 1 if you have the `putenv' function. */
+#undef HAVE_PUTENV
+
+/* Define to 1 if you have the <pwd.h> header file. */
+#undef HAVE_PWD_H
+
+/* Define to 1 if your system has a GNU libc compatible `realloc' function,
+ and to 0 otherwise. */
+#undef HAVE_REALLOC
+
+/* Enable Rust language */
+#undef HAVE_RUST
+
+/* Define to 1 if you have the <sched.h> header file. */
+#undef HAVE_SCHED_H
+
+/* Define to 1 if you have the `select' function. */
+#undef HAVE_SELECT
+
+/* Define to 1 if you have the `setenv' function. */
+#undef HAVE_SETENV
+
+/* Define to 1 if you have the `setrlimit' function. */
+#undef HAVE_SETRLIMIT
+
+/* Define to 1 if you have the <signal.h> header file. */
+#undef HAVE_SIGNAL_H
+
+/* Define to 1 if you have the `socket' function. */
+#undef HAVE_SOCKET
+
+/* Define to 1 if you have the <stdarg.h> header file. */
+#undef HAVE_STDARG_H
+
+/* Define to 1 if you have the <stdatomic.h> header file. */
+#undef HAVE_STDATOMIC_H
+
+/* Define to 1 if stdbool.h conforms to C99. */
+#undef HAVE_STDBOOL_H
+
+/* Define to 1 if you have the <stddef.h> header file. */
+#undef HAVE_STDDEF_H
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#undef HAVE_STDINT_H
+
+/* Define to 1 if you have the <stdio.h> header file. */
+#undef HAVE_STDIO_H
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#undef HAVE_STDLIB_H
+
+/* Define to 1 if you have the `strcasecmp' function. */
+#undef HAVE_STRCASECMP
+
+/* Define to 1 if you have the `strchr' function. */
+#undef HAVE_STRCHR
+
+/* Define to 1 if you have the `strdup' function. */
+#undef HAVE_STRDUP
+
+/* Define to 1 if you have the `strerror' function. */
+#undef HAVE_STRERROR
+
+/* Define to 1 if you have the <strings.h> header file. */
+#undef HAVE_STRINGS_H
+
+/* Define to 1 if you have the <string.h> header file. */
+#undef HAVE_STRING_H
+
+/* Define to 1 if you have the `strlcat' function. */
+#undef HAVE_STRLCAT
+
+/* Define to 1 if you have the `strlcpy' function. */
+#undef HAVE_STRLCPY
+
+/* Define to 1 if you have the `strncasecmp' function. */
+#undef HAVE_STRNCASECMP
+
+/* Define to 1 if you have the `strndup' function. */
+#undef HAVE_STRNDUP
+
+/* Define to 1 if you have the `strpbrk' function. */
+#undef HAVE_STRPBRK
+
+/* Define to 1 if you have the `strptime' function. */
+#undef HAVE_STRPTIME
+
+/* Define to 1 if you have the `strrchr' function. */
+#undef HAVE_STRRCHR
+
+/* Define to 1 if you have the `strstr' function. */
+#undef HAVE_STRSTR
+
+/* Define to 1 if you have the `strtol' function. */
+#undef HAVE_STRTOL
+
+/* Define to 1 if you have the `strtoul' function. */
+#undef HAVE_STRTOUL
+
+/* Define to 1 if you have the `strtoull' function. */
+#undef HAVE_STRTOULL
+
+/* Define to 1 if you have the `strtoumax' function. */
+#undef HAVE_STRTOUMAX
+
+/* Define to 1 if `tm_zone' is a member of `struct tm'. */
+#undef HAVE_STRUCT_TM_TM_ZONE
+
+/* Define to 1 if you have the <syslog.h> header file. */
+#undef HAVE_SYSLOG_H
+
+/* Define to 1 if you have the <sys/ioctl.h> header file. */
+#undef HAVE_SYS_IOCTL_H
+
+/* Define to 1 if you have the <sys/mman.h> header file. */
+#undef HAVE_SYS_MMAN_H
+
+/* Define to 1 if you have the <sys/param.h> header file. */
+#undef HAVE_SYS_PARAM_H
+
+/* Define to 1 if you have the <sys/prctl.h> header file. */
+#undef HAVE_SYS_PRCTL_H
+
+/* Define to 1 if you have the <sys/queue.h> header file. */
+#undef HAVE_SYS_QUEUE_H
+
+/* Define to 1 if you have the <sys/random.h> header file. */
+#undef HAVE_SYS_RANDOM_H
+
+/* Define to 1 if you have the <sys/resource.h> header file. */
+#undef HAVE_SYS_RESOURCE_H
+
+/* Define to 1 if you have the <sys/socket.h> header file. */
+#undef HAVE_SYS_SOCKET_H
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#undef HAVE_SYS_STAT_H
+
+/* Define to 1 if you have the <sys/syscall.h> header file. */
+#undef HAVE_SYS_SYSCALL_H
+
+/* Define to 1 if you have the <sys/time.h> header file. */
+#undef HAVE_SYS_TIME_H
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#undef HAVE_SYS_TYPES_H
+
+/* Define to 1 if you have the <sys/un.h> header file. */
+#undef HAVE_SYS_UN_H
+
+/* Define to 1 if you have the <time.h> header file. */
+#undef HAVE_TIME_H
+
+/* Define to 1 if your `struct tm' has `tm_zone'. Deprecated, use
+ `HAVE_STRUCT_TM_TM_ZONE' instead. */
+#undef HAVE_TM_ZONE
+
+/* AF_PACKET tpcket_v3 support is available */
+#undef HAVE_TPACKET_V3
+
+/* Define to 1 if you don't have `tm_zone' but do have the external array
+ `tzname'. */
+#undef HAVE_TZNAME
+
+/* Define to 1 if you have the `tzset' function. */
+#undef HAVE_TZSET
+
+/* Define to 1 if you have the `uname' function. */
+#undef HAVE_UNAME
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#undef HAVE_UNISTD_H
+
+/* Define to 1 if you have the `utime' function. */
+#undef HAVE_UTIME
+
+/* Define to 1 if you have the <utime.h> header file. */
+#undef HAVE_UTIME_H
+
+/* Define to 1 if you have the `vfork' function. */
+#undef HAVE_VFORK
+
+/* Define to 1 if you have the <vfork.h> header file. */
+#undef HAVE_VFORK_H
+
+/* Define to 1 if you have the <w32api/winbase.h> header file. */
+#undef HAVE_W32API_WINBASE_H
+
+/* Define to 1 if you have the <w32api/wtypes.h> header file. */
+#undef HAVE_W32API_WTYPES_H
+
+/* Define to 1 if you have the <wincrypt.h> header file. */
+#undef HAVE_WINCRYPT_H
+
+/* Define to 1 if you have the <windows.h> header file. */
+#undef HAVE_WINDOWS_H
+
+/* Define to 1 if you have the <winsock2.h> header file. */
+#undef HAVE_WINSOCK2_H
+
+/* Define to 1 if `fork' works. */
+#undef HAVE_WORKING_FORK
+
+/* Define to 1 if `vfork' works. */
+#undef HAVE_WORKING_VFORK
+
+/* Define to 1 if you have the <ws2tcpip.h> header file. */
+#undef HAVE_WS2TCPIP_H
+
+/* Define to 1 if you have the <xdp/xsk.h> header file. */
+#undef HAVE_XDP_XSK_H
+
+/* Define to 1 if the system has the type `_Bool'. */
+#undef HAVE__BOOL
+
+/* Enable FreeBSD IPFW support for inline IDP */
+#undef IPFW
+
+/* Define to the sub-directory where libtool stores uninstalled libraries. */
+#undef LT_OBJDIR
+
+/* (Napatech flowdirector support) */
+#undef NAPATECH_ENABLE_BYPASS
+
+/* Enable Linux Netfilter NFQUEUE support for inline IDP */
+#undef NFQ
+
+/* For signed version of nfq_get_payload */
+#undef NFQ_GET_PAYLOAD_SIGNED
+
+/* Name of package */
+#undef PACKAGE
+
+/* Define to the address where bug reports for this package should be sent. */
+#undef PACKAGE_BUGREPORT
+
+/* Define to the full name of this package. */
+#undef PACKAGE_NAME
+
+/* Define to the full name and version of this package. */
+#undef PACKAGE_STRING
+
+/* Define to the one symbol short name of this package. */
+#undef PACKAGE_TARNAME
+
+/* Define to the home page for this package. */
+#undef PACKAGE_URL
+
+/* Define to the version of this package. */
+#undef PACKAGE_VERSION
+
+/* Pcre code unit width is 8 bits */
+#undef PCRE2_CODE_UNIT_WIDTH
+
+/* Pcre2 with JIT compiler support enabled */
+#undef PCRE2_HAVE_JIT
+
+/* Enable performance profiling for locks */
+#undef PROFILE_LOCKING
+
+/* Enable performance profiling for rules */
+#undef PROFILE_RULES
+
+/* Enable performance profiling */
+#undef PROFILING
+
+/* Git revision */
+#undef REVISION
+
+/* Define to 1 if all of the C90 standard headers exist (not just the ones
+ required in a freestanding environment). This macro is provided for
+ backward compatibility; new code need not use it. */
+#undef STDC_HEADERS
+
+/* C11 Thread local storage */
+#undef TLS_C11
+
+/* Thread local storage */
+#undef TLS_GNU
+
+/* Define to 1 if your <sys/time.h> declares `struct tm'. */
+#undef TM_IN_SYS_TIME
+
+/* Enable built-in unittests */
+#undef UNITTESTS
+
+/* Version number of package */
+#undef VERSION
+
+/* Enable Windows WinDivert support for inline IDP */
+#undef WINDIVERT
+
+/* (bsd source) */
+#undef _BSD_SOURCE
+
+/* (default source) */
+#undef _DEFAULT_SOURCE
+
+/* Number of bits in a file offset, on hosts where this is settable. */
+#undef _FILE_OFFSET_BITS
+
+/* Define for large files, on AIX-style hosts. */
+#undef _LARGE_FILES
+
+/* Define for Solaris 2.5.1 so the uint32_t typedef from <sys/synch.h>,
+ <pthread.h>, or <semaphore.h> is not used. If the typedef was allowed, the
+ #define below would cause a syntax error. */
+#undef _UINT32_T
+
+/* Define for Solaris 2.5.1 so the uint64_t typedef from <sys/synch.h>,
+ <pthread.h>, or <semaphore.h> is not used. If the typedef was allowed, the
+ #define below would cause a syntax error. */
+#undef _UINT64_T
+
+/* Define for Solaris 2.5.1 so the uint8_t typedef from <sys/synch.h>,
+ <pthread.h>, or <semaphore.h> is not used. If the typedef was allowed, the
+ #define below would cause a syntax error. */
+#undef _UINT8_T
+
+/* (bsd source) */
+#undef __BSD_SOURCE
+
+/* (favor bsd) */
+#undef __FAVOR_BSD
+
+/* Define to `__inline__' or `__inline' if that's what the C compiler
+ calls it, or to nothing if 'inline' is not supported under any name. */
+#ifndef __cplusplus
+#undef inline
+#endif
+
+/* Define to the type of a signed integer type of width exactly 16 bits if
+ such a type exists and the standard includes do not define it. */
+#undef int16_t
+
+/* Define to the type of a signed integer type of width exactly 32 bits if
+ such a type exists and the standard includes do not define it. */
+#undef int32_t
+
+/* Define to the type of a signed integer type of width exactly 64 bits if
+ such a type exists and the standard includes do not define it. */
+#undef int64_t
+
+/* Define to the type of a signed integer type of width exactly 8 bits if such
+ a type exists and the standard includes do not define it. */
+#undef int8_t
+
+/* Define to rpl_malloc if the replacement function should be used. */
+#undef malloc
+
+/* Define to `int' if <sys/types.h> does not define. */
+#undef mode_t
+
+/* Define as a signed integer type capable of holding a process identifier. */
+#undef pid_t
+
+/* Define to rpl_realloc if the replacement function should be used. */
+#undef realloc
+
+/* Define to the equivalent of the C99 'restrict' keyword, or to
+ nothing if this is not supported. Do not define if restrict is
+ supported only directly. */
+#undef restrict
+/* Work around a bug in older versions of Sun C++, which did not
+ #define __restrict__ or support _Restrict or __restrict__
+ even though the corresponding Sun C compiler ended up with
+ "#define restrict _Restrict" or "#define restrict __restrict__"
+ in the previous line. This workaround can be removed once
+ we assume Oracle Developer Studio 12.5 (2016) or later. */
+#if defined __SUNPRO_CC && !defined __RESTRICT && !defined __restrict__
+# define _Restrict
+# define __restrict__
+#endif
+
+/* Define to `unsigned int' if <sys/types.h> does not define. */
+#undef size_t
+
+/* Define to `int' if <sys/types.h> does not define. */
+#undef ssize_t
+
+/* Define to the type of an unsigned integer type of width exactly 16 bits if
+ such a type exists and the standard includes do not define it. */
+#undef uint16_t
+
+/* Define to the type of an unsigned integer type of width exactly 32 bits if
+ such a type exists and the standard includes do not define it. */
+#undef uint32_t
+
+/* Define to the type of an unsigned integer type of width exactly 64 bits if
+ such a type exists and the standard includes do not define it. */
+#undef uint64_t
+
+/* Define to the type of an unsigned integer type of width exactly 8 bits if
+ such a type exists and the standard includes do not define it. */
+#undef uint8_t
+
+/* Define as `fork' if `vfork' does not work. */
+#undef vfork