summaryrefslogtreecommitdiffstats
path: root/suricata-update/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'suricata-update/Makefile')
-rw-r--r--suricata-update/Makefile595
1 files changed, 595 insertions, 0 deletions
diff --git a/suricata-update/Makefile b/suricata-update/Makefile
new file mode 100644
index 0000000..26f2753
--- /dev/null
+++ b/suricata-update/Makefile
@@ -0,0 +1,595 @@
+# Makefile.in generated by automake 1.16.5 from Makefile.am.
+# suricata-update/Makefile. Generated from Makefile.in by configure.
+
+# Copyright (C) 1994-2021 Free Software Foundation, Inc.
+
+# This Makefile.in is free software; the Free Software Foundation
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
+
+
+
+am__is_gnu_make = { \
+ if test -z '$(MAKELEVEL)'; then \
+ false; \
+ elif test -n '$(MAKE_HOST)'; then \
+ true; \
+ elif test -n '$(MAKE_VERSION)' && test -n '$(CURDIR)'; then \
+ true; \
+ else \
+ false; \
+ fi; \
+}
+am__make_running_with_option = \
+ case $${target_option-} in \
+ ?) ;; \
+ *) echo "am__make_running_with_option: internal error: invalid" \
+ "target option '$${target_option-}' specified" >&2; \
+ exit 1;; \
+ esac; \
+ has_opt=no; \
+ sane_makeflags=$$MAKEFLAGS; \
+ if $(am__is_gnu_make); then \
+ sane_makeflags=$$MFLAGS; \
+ else \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ bs=\\; \
+ sane_makeflags=`printf '%s\n' "$$MAKEFLAGS" \
+ | sed "s/$$bs$$bs[$$bs $$bs ]*//g"`;; \
+ esac; \
+ fi; \
+ skip_next=no; \
+ strip_trailopt () \
+ { \
+ flg=`printf '%s\n' "$$flg" | sed "s/$$1.*$$//"`; \
+ }; \
+ for flg in $$sane_makeflags; do \
+ test $$skip_next = yes && { skip_next=no; continue; }; \
+ case $$flg in \
+ *=*|--*) continue;; \
+ -*I) strip_trailopt 'I'; skip_next=yes;; \
+ -*I?*) strip_trailopt 'I';; \
+ -*O) strip_trailopt 'O'; skip_next=yes;; \
+ -*O?*) strip_trailopt 'O';; \
+ -*l) strip_trailopt 'l'; skip_next=yes;; \
+ -*l?*) strip_trailopt 'l';; \
+ -[dEDm]) skip_next=yes;; \
+ -[JT]) skip_next=yes;; \
+ esac; \
+ case $$flg in \
+ *$$target_option*) has_opt=yes; break;; \
+ esac; \
+ done; \
+ test $$has_opt = yes
+am__make_dryrun = (target_option=n; $(am__make_running_with_option))
+am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
+pkgdatadir = $(datadir)/suricata
+pkgincludedir = $(includedir)/suricata
+pkglibdir = $(libdir)/suricata
+pkglibexecdir = $(libexecdir)/suricata
+am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+install_sh_DATA = $(install_sh) -c -m 644
+install_sh_PROGRAM = $(install_sh) -c
+install_sh_SCRIPT = $(install_sh) -c
+INSTALL_HEADER = $(INSTALL_DATA)
+transform = $(program_transform_name)
+NORMAL_INSTALL = :
+PRE_INSTALL = :
+POST_INSTALL = :
+NORMAL_UNINSTALL = :
+PRE_UNINSTALL = :
+POST_UNINSTALL = :
+build_triplet = x86_64-pc-linux-gnu
+host_triplet = x86_64-pc-linux-gnu
+subdir = suricata-update
+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
+ $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
+ $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
+ $(top_srcdir)/configure.ac
+am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+DIST_COMMON = $(srcdir)/Makefile.am $(am__DIST_COMMON)
+mkinstalldirs = $(install_sh) -d
+CONFIG_HEADER = $(top_builddir)/src/autoconf.h
+CONFIG_CLEAN_FILES =
+CONFIG_CLEAN_VPATH_FILES =
+AM_V_P = $(am__v_P_$(V))
+am__v_P_ = $(am__v_P_$(AM_DEFAULT_VERBOSITY))
+am__v_P_0 = false
+am__v_P_1 = :
+AM_V_GEN = $(am__v_GEN_$(V))
+am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+am__v_GEN_0 = @echo " GEN " $@;
+am__v_GEN_1 =
+AM_V_at = $(am__v_at_$(V))
+am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
+am__v_at_0 = @
+am__v_at_1 =
+SOURCES =
+DIST_SOURCES =
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
+am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
+am__DIST_COMMON = $(srcdir)/Makefile.in
+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ACLOCAL = ${SHELL} '/builds/dev/suricata/missing' aclocal-1.16
+AMTAR = $${TAR-tar}
+AM_DEFAULT_VERBOSITY = 0
+AR = ar
+AUTOCONF = ${SHELL} '/builds/dev/suricata/missing' autoconf
+AUTOHEADER = ${SHELL} '/builds/dev/suricata/missing' autoheader
+AUTOMAKE = ${SHELL} '/builds/dev/suricata/missing' automake-1.16
+AWK = mawk
+CARGO = /usr/bin/cargo
+CARGO_BUILD_TARGET =
+CARGO_HOME = /root/.cargo
+CBINDGEN = /usr/bin/cbindgen
+CC = gcc
+CCDEPMODE = depmode=gcc3
+CFLAGS = -g -O2 -fPIC -std=c11 -march=native -I${srcdir}/../rust/gen -I${srcdir}/../rust/dist
+CLANG =
+CLANG_CFLAGS =
+CONFIGURE_DATAROOTDIR = /usr/local/share
+CONFIGURE_LOCALSTATEDIR = /usr/local/var
+CONFIGURE_PREFIX = /usr/local
+CONFIGURE_SYSCONDIR = /usr/local/etc
+CPP = gcc -E
+CPPFLAGS = -I${srcdir}/../libhtp/ -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -D__SCFILENAME__=\"$(*F)\"
+CSCOPE = cscope
+CTAGS = ctags
+CXX = g++
+CXXCPP = g++ -E
+CXXDEPMODE = depmode=gcc3
+CXXFLAGS = -g -O2
+CYGPATH_W = echo
+DEFS = -DHAVE_CONFIG_H
+DEPDIR = .deps
+DLLTOOL = false
+DSYMUTIL =
+DUMPBIN =
+ECHO_C =
+ECHO_N = -n
+ECHO_T =
+EGREP = /usr/bin/grep -E
+ETAGS = etags
+EXEEXT =
+FGREP = /usr/bin/grep -F
+FILECMD = file
+GCC_CFLAGS = -Wextra -Werror-implicit-function-declaration
+GREP = /usr/bin/grep
+HAVE_COCCINELLE_CONFIG = no
+HAVE_CURL = /usr/bin/curl
+HAVE_CYGPATH = no
+HAVE_GETCONF_CMD = /usr/bin/getconf
+HAVE_GIT_CMD = /usr/bin/git
+HAVE_PCAP_CONFIG = /usr/bin/pcap-config
+HAVE_PDFLATEX = /usr/bin/pdflatex
+HAVE_PKG_CONFIG = /usr/bin/pkg-config
+HAVE_PYTHON = /usr/bin/python3
+HAVE_WGET = no
+HTP_DIR = libhtp
+HTP_LDADD = ../libhtp/htp/libhtp.la
+INSTALL = /usr/bin/install -c
+INSTALL_DATA = ${INSTALL} -m 644
+INSTALL_PROGRAM = ${INSTALL}
+INSTALL_SCRIPT = ${INSTALL}
+INSTALL_STRIP_PROGRAM = $(install_sh) -c -s
+LD = /usr/bin/ld -m elf_x86_64
+LDFLAGS = -rdynamic
+LIBHTPDEVVERSION_CFLAGS =
+LIBHTPDEVVERSION_LIBS =
+LIBHTPMINVERSION_CFLAGS =
+LIBHTPMINVERSION_LIBS =
+LIBOBJS =
+LIBS = \
+ suricata/__init__.py \
+ suricata/update/commands/__init__.py \
+ suricata/update/commands/addsource.py \
+ suricata/update/commands/checkversions.py \
+ suricata/update/commands/disablesource.py \
+ suricata/update/commands/enablesource.py \
+ suricata/update/commands/listsources.py \
+ suricata/update/commands/removesource.py \
+ suricata/update/commands/updatesources.py \
+ suricata/update/compat/__init__.py \
+ suricata/update/compat/ordereddict.py \
+ suricata/update/compat/argparse/__init__.py \
+ suricata/update/compat/argparse/argparse.py \
+ suricata/update/configs/__init__.py \
+ suricata/update/config.py \
+ suricata/update/data/__init__.py \
+ suricata/update/data/index.py \
+ suricata/update/data/update.py \
+ suricata/update/__init__.py \
+ suricata/update/engine.py \
+ suricata/update/exceptions.py \
+ suricata/update/extract.py \
+ suricata/update/loghandler.py \
+ suricata/update/main.py \
+ suricata/update/maps.py \
+ suricata/update/matchers.py \
+ suricata/update/net.py \
+ suricata/update/notes.py \
+ suricata/update/osinfo.py \
+ suricata/update/parsers.py \
+ suricata/update/rule.py \
+ suricata/update/sources.py \
+ suricata/update/util.py \
+ suricata/update/version.py
+
+LIBTOOL = $(SHELL) $(top_builddir)/libtool
+LIB_FUZZING_ENGINE =
+LIPO =
+LLC =
+LN_S = ln -s
+LTLIBOBJS =
+LT_SYS_LIBRARY_PATH =
+LUAJIT_CFLAGS =
+LUAJIT_LIBS =
+LUA_CFLAGS =
+LUA_INT8 =
+LUA_LIBS =
+MAJOR_MINOR = 7.0
+MAKEINFO = ${SHELL} '/builds/dev/suricata/missing' makeinfo
+MANIFEST_TOOL = :
+MKDIR_P = /usr/bin/mkdir -p
+NM = /usr/bin/nm -B
+NMEDIT =
+OBJDUMP = objdump
+OBJEXT = o
+OPTIMIZATION_CFLAGS = -march=native
+OTOOL =
+OTOOL64 =
+PACKAGE = suricata
+PACKAGE_BUGREPORT =
+PACKAGE_NAME = suricata
+PACKAGE_STRING = suricata 7.0.3
+PACKAGE_TARNAME = suricata
+PACKAGE_URL =
+PACKAGE_VERSION = 7.0.3
+PATH_SEPARATOR = :
+PCAP_CFLAGS = -I/usr/include
+PCAP_LIBS = -lpcap
+PKG_CONFIG = /usr/bin/pkg-config
+PKG_CONFIG_LIBDIR =
+PKG_CONFIG_PATH =
+POW_LIB =
+RANLIB = ranlib
+RUSTC = /usr/bin/rustc
+RUSTUP_HOME_PATH = no
+RUST_FEATURES =
+RUST_LDADD = -ldl -lrt -lm
+RUST_SURICATA_LIB = ../rust/target/release/libsuricata_rust.a
+RUST_SURICATA_LIBDIR = ../rust/target/release
+RUST_SURICATA_LIBNAME = libsuricata_rust.a
+SECCFLAGS =
+SECLDFLAGS =
+SED = /usr/bin/sed
+SET_MAKE =
+SHELL = /bin/bash
+SPHINX_BUILD = /usr/bin/sphinx-build
+STRIP = strip
+SURICATA_UPDATE_DIR = suricata-update
+VERSION = 7.0.3
+abs_builddir = /builds/dev/suricata/suricata-update
+abs_srcdir = /builds/dev/suricata/suricata-update
+abs_top_builddir = /builds/dev/suricata
+abs_top_srcdir = /builds/dev/suricata
+ac_ct_AR = ar
+ac_ct_CC = gcc
+ac_ct_CXX = g++
+ac_ct_DUMPBIN =
+am__include = include
+am__leading_dot = .
+am__quote =
+am__tar = tar --format=ustar -chf - "$$tardir"
+am__untar = tar -xf -
+bindir = ${exec_prefix}/bin
+build = x86_64-pc-linux-gnu
+build_alias =
+build_cpu = x86_64
+build_os = linux-gnu
+build_vendor = pc
+builddir = .
+datadir = ${datarootdir}
+datarootdir = ${prefix}/share
+docdir = ${datarootdir}/doc/${PACKAGE_TARNAME}
+dvidir = ${docdir}
+e_datadir = /usr/local/var/lib/suricata/data
+e_datarulesdir = /usr/local/share/suricata/rules
+e_defaultruledir = /usr/local/var/lib/suricata/rules
+e_enable_evelog = yes
+e_localstatedir = /usr/local/var/run/suricata
+e_logcertsdir = /usr/local/var/log/suricata/certs
+e_logdir = /usr/local/var/log/suricata/
+e_logfilesdir = /usr/local/var/log/suricata/files
+e_magic_file =
+e_magic_file_comment = #
+e_rundir = /usr/local/var/run/
+e_rustdir = /builds/dev/suricata/rust
+e_sysconfdir = /usr/local/etc/suricata/
+enable_non_bundled_htp = no
+exec_prefix = ${prefix}
+have_rustup = no
+host = x86_64-pc-linux-gnu
+host_alias =
+host_cpu = x86_64
+host_os = linux-gnu
+host_vendor = pc
+htmldir = ${docdir}
+includedir = ${prefix}/include
+infodir = ${datarootdir}/info
+install_sh = ${SHELL} /builds/dev/suricata/install-sh
+install_suricata_update_reason =
+libdir = ${exec_prefix}/lib
+libexecdir = ${exec_prefix}/libexec
+libhs_CFLAGS =
+libhs_LIBS =
+libhtp_CFLAGS =
+libhtp_LIBS =
+libnetfilter_queue_CFLAGS =
+libnetfilter_queue_LIBS =
+localedir = ${datarootdir}/locale
+localstatedir = ${prefix}/var
+mandir = ${datarootdir}/man
+mkdir_p = $(MKDIR_P)
+oldincludedir = /usr/include
+pdfdir = ${docdir}
+prefix = /usr/local
+program_transform_name = s,x,x,
+psdir = ${docdir}
+runstatedir = ${localstatedir}/run
+rust_vendor_comment = #
+rustup_home =
+sbindir = ${exec_prefix}/sbin
+sharedstatedir = ${prefix}/com
+srcdir = .
+subdirs = libhtp
+sysconfdir = ${prefix}/etc
+target_alias =
+top_build_prefix = ../
+top_builddir = ..
+top_srcdir = ..
+CONFIGS = \
+ suricata/update/configs/disable.conf \
+ suricata/update/configs/drop.conf \
+ suricata/update/configs/enable.conf \
+ suricata/update/configs/modify.conf \
+ suricata/update/configs/threshold.in \
+ suricata/update/configs/update.yaml
+
+BINS = suricata-update
+all: all-am
+
+.SUFFIXES:
+$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
+ @for dep in $?; do \
+ case '$(am__configure_deps)' in \
+ *$$dep*) \
+ ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
+ && { if test -f $@; then exit 0; else break; fi; }; \
+ exit 1;; \
+ esac; \
+ done; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu suricata-update/Makefile'; \
+ $(am__cd) $(top_srcdir) && \
+ $(AUTOMAKE) --gnu suricata-update/Makefile
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ @case '$?' in \
+ *config.status*) \
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
+ *) \
+ echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__maybe_remake_depfiles)'; \
+ cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__maybe_remake_depfiles);; \
+ esac;
+
+$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+
+$(top_srcdir)/configure: $(am__configure_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(am__aclocal_m4_deps):
+
+mostlyclean-libtool:
+ -rm -f *.lo
+
+clean-libtool:
+ -rm -rf .libs _libs
+tags TAGS:
+
+ctags CTAGS:
+
+cscope cscopelist:
+
+distdir: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) distdir-am
+
+distdir-am: $(DISTFILES)
+ @srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
+ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
+ list='$(DISTFILES)'; \
+ dist_files=`for file in $$list; do echo $$file; done | \
+ sed -e "s|^$$srcdirstrip/||;t" \
+ -e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t"`; \
+ case $$dist_files in \
+ */*) $(MKDIR_P) `echo "$$dist_files" | \
+ sed '/\//!d;s|^|$(distdir)/|;s,/[^/]*$$,,' | \
+ sort -u` ;; \
+ esac; \
+ for file in $$dist_files; do \
+ if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
+ if test -d $$d/$$file; then \
+ dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test -d "$(distdir)/$$file"; then \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
+ fi; \
+ if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
+ fi; \
+ cp -fpR $$d/$$file "$(distdir)$$dir" || exit 1; \
+ else \
+ test -f "$(distdir)/$$file" \
+ || cp -p $$d/$$file "$(distdir)/$$file" \
+ || exit 1; \
+ fi; \
+ done
+check-am: all-am
+check: check-am
+all-am: Makefile
+installdirs:
+install: install-am
+install-exec: install-exec-am
+install-data: install-data-am
+uninstall: uninstall-am
+
+install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+
+installcheck: installcheck-am
+install-strip:
+ if test -z '$(STRIP)'; then \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ install; \
+ else \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
+ fi
+mostlyclean-generic:
+
+clean-generic:
+
+distclean-generic:
+ -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+ -test . = "$(srcdir)" || test -z "$(CONFIG_CLEAN_VPATH_FILES)" || rm -f $(CONFIG_CLEAN_VPATH_FILES)
+
+maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+ @echo "it deletes files that may require special tools to rebuild."
+#clean-local:
+#install-exec-local:
+#uninstall-local:
+clean: clean-am
+
+clean-am: clean-generic clean-libtool clean-local mostlyclean-am
+
+distclean: distclean-am
+ -rm -f Makefile
+distclean-am: clean-am distclean-generic
+
+dvi: dvi-am
+
+dvi-am:
+
+html: html-am
+
+html-am:
+
+info: info-am
+
+info-am:
+
+install-data-am:
+
+install-dvi: install-dvi-am
+
+install-dvi-am:
+
+install-exec-am: install-exec-local
+
+install-html: install-html-am
+
+install-html-am:
+
+install-info: install-info-am
+
+install-info-am:
+
+install-man:
+
+install-pdf: install-pdf-am
+
+install-pdf-am:
+
+install-ps: install-ps-am
+
+install-ps-am:
+
+installcheck-am:
+
+maintainer-clean: maintainer-clean-am
+ -rm -f Makefile
+maintainer-clean-am: distclean-am maintainer-clean-generic
+
+mostlyclean: mostlyclean-am
+
+mostlyclean-am: mostlyclean-generic mostlyclean-libtool
+
+pdf: pdf-am
+
+pdf-am:
+
+ps: ps-am
+
+ps-am:
+
+uninstall-am: uninstall-local
+
+.MAKE: install-am install-strip
+
+.PHONY: all all-am check check-am clean clean-generic clean-libtool \
+ clean-local cscopelist-am ctags-am distclean distclean-generic \
+ distclean-libtool distdir dvi dvi-am html html-am info info-am \
+ install install-am install-data install-data-am install-dvi \
+ install-dvi-am install-exec install-exec-am install-exec-local \
+ install-html install-html-am install-info install-info-am \
+ install-man install-pdf install-pdf-am install-ps \
+ install-ps-am install-strip installcheck installcheck-am \
+ installdirs maintainer-clean maintainer-clean-generic \
+ mostlyclean mostlyclean-generic mostlyclean-libtool pdf pdf-am \
+ ps ps-am tags-am uninstall uninstall-am uninstall-local
+
+.PRECIOUS: Makefile
+
+
+install-exec-local:
+ install -d -m 0755 "$(DESTDIR)$(prefix)/lib/suricata/python/suricata/update/commands"
+ install -d -m 0755 "$(DESTDIR)$(prefix)/lib/suricata/python/suricata/update/compat/argparse"
+ install -d -m 0755 "$(DESTDIR)$(prefix)/lib/suricata/python/suricata/update/configs"
+ install -d -m 0755 "$(DESTDIR)$(prefix)/lib/suricata/python/suricata/update/data"
+ for lib in $(LIBS); do \
+ install $(srcdir)/$$lib "$(DESTDIR)$(prefix)/lib/suricata/python/$$lib"; \
+ done
+ for config in $(CONFIGS); do \
+ install -m 0644 $(srcdir)/$$config "$(DESTDIR)$(prefix)/lib/suricata/python/$$config"; \
+ done
+ for bin in $(BINS); do \
+ cat "$(srcdir)/bin/$$bin" | \
+ sed -e "1 s,.*,#"'!'" ${HAVE_PYTHON}," > "${DESTDIR}$(bindir)/$$bin"; \
+ chmod 0755 "$(DESTDIR)$(bindir)/$$bin"; \
+ done
+
+uninstall-local:
+ rm -f $(DESTDIR)$(bindir)/suricata-update
+ rm -rf $(DESTDIR)$(prefix)/lib/suricata/python
+
+clean-local:
+ find . -name \*.pyc -print0 | xargs -0 rm -f
+
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT: