summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:18:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:18:34 +0000
commitc19c886707c32e5c448711985a42df533671bd4a (patch)
tree8476c2cb952446987e0033e903634ba7aea271b2 /debian
parentMerging upstream version 256.2. (diff)
downloadsystemd-c19c886707c32e5c448711985a42df533671bd4a.tar.xz
systemd-c19c886707c32e5c448711985a42df533671bd4a.zip
Adding debian version 256.2-1.debian/256.2-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/control1
-rwxr-xr-xdebian/extra/checkout-upstream57
-rwxr-xr-xdebian/extra/initramfs-tools/hooks/udev4
-rw-r--r--debian/not-installed2
-rwxr-xr-xdebian/systemd-container.install3
-rwxr-xr-xdebian/systemd-container.manpages1
-rwxr-xr-xdebian/systemd.install1
-rwxr-xr-xdebian/tests/upstream3
9 files changed, 60 insertions, 30 deletions
diff --git a/debian/changelog b/debian/changelog
index b2cc7d0..f2c4836 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+systemd (256.2-1) unstable; urgency=medium
+
+ * d/not-installed: fix shutdown.standalone path
+ * autopkgtest: skip qemu tests on arm64
+ * Add recommends on linux-sysctl-defaults. This package contains the
+ default sysctl settings, and is maintained by the kernel team. This is
+ not available in Ubuntu so keep it as a recommends for now, to avoid
+ breaking the upstream CI.
+ (Closes: #1027773)
+ * initramfs-tools: copy network drop-ins too (Closes: #1074564)
+ * d/e/checkout-upstream: fix shellcheck warnings
+ * d/e/checkout-upstream: do not fail if rebase fails
+ * d/e/checkout-upstream: switch packaging branch on upstream stable PRs.
+ * New upstream version 256.2 (Closes: #1074789)
+ * Install run0 zsh completion file
+
+ -- Luca Boccassi <bluca@debian.org> Fri, 05 Jul 2024 19:15:59 +0100
+
systemd (256.1-2) unstable; urgency=medium
* Bump breaks/replaces to conflicts for DEP17. Breaks/replaces are not
diff --git a/debian/control b/debian/control
index 4bccb60..4dcbf23 100644
--- a/debian/control
+++ b/debian/control
@@ -90,6 +90,7 @@ Architecture: linux-any
Multi-Arch: foreign
Priority: important
Recommends: default-dbus-system-bus | dbus-system-bus,
+ linux-sysctl-defaults,
systemd-timesyncd | time-daemon,
systemd-cryptsetup,
${dlopen:Recommends},
diff --git a/debian/extra/checkout-upstream b/debian/extra/checkout-upstream
index 68afd43..025b1df 100755
--- a/debian/extra/checkout-upstream
+++ b/debian/extra/checkout-upstream
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Prepare systemd source package in current directory for testing an upstream
# commit, branch, or PR, without Debian patches. This replaces everything
# except the debian/ directory with an upstream checkout.
@@ -41,13 +41,38 @@ if [ -d .git ]; then
git config --get user.email || git config user.email "$DUMMY_USER_EMAIL"
fi
+mkdir -p debian/tmp
+(cd debian/tmp
+ git clone "${UPSTREAM_REPO}" upstream || (rm -rf upstream; sleep 60; git clone "${UPSTREAM_REPO}" upstream)
+ cd upstream
+ $FETCH
+ $CO
+ git config user.email "$DUMMY_USER_EMAIL"
+ git config user.name "$DUMMY_USER_NAME"
+ if [ -n "${UPSTREAM_PULL_REQUEST:-}" ] && [ "${UPSTREAM_REPO}" != "https://github.com/systemd/systemd-stable.git" ]; then
+ git rebase main || git rebase --abort
+ fi
+)
+if [ -f debian/tmp/upstream/meson.version ]; then
+ UPSTREAM_VER=$(cat debian/tmp/upstream/meson.version)
+else
+ UPSTREAM_VER=$(cd debian/tmp/upstream; git describe | sed 's/^v//;s/-/./g')
+fi
+
+# If we are on a stable branch, check out the corresponding packaging branch. For some settings like
+# build dependencies it is already too late, but this is mostly relevant for the dh_install files and
+# the tests.
+if [ -d .git ] && echo "$UPSTREAM_VER" | grep -q '\.'; then
+ git checkout "ci/v${UPSTREAM_VER%%.*}-stable"
+fi
+
if [ -n "${KEEP_DEBIAN_PATCHES:-}" ]; then
# set up pq branch if it does not exist
if [ "$BRANCH_NAME" = HEAD ]; then
echo "ERROR: $0 must be started from a branch when using KEEP_DEBIAN_PATCHES" >&2
exit 1
fi
- gbp pq import 2> /dev/null && gbp pq switch || true
+ ( gbp pq import 2> /dev/null && gbp pq switch ) || true
if ! git branch --contains "$BRANCH_NAME" | grep -q patch-queue/"$BRANCH_NAME"; then
echo "ERROR: patch-queue/$BRANCH_NAME exists but it is not rebased, please rebase it." >&2
exit 1
@@ -64,33 +89,13 @@ rm -rf debian/patches
[ -n "${KEEP_DEBIAN_TESTS:-}" ] || sed -i '/# NOUPSTREAM/ q' debian/tests/control
# create new git commit with debian/ changes
-if [ -d .git -a -n "$(git status --short debian)" ]; then
+if [ -d .git ] && [ -n "$(git status --short debian)" ]; then
git add debian
git commit -n -m "checkout-upstream: edit debian/ files for upstream testing"
fi
-########
-# Everything below this changes only code outside debian/
-# besides temporary use of debian/tmp/
-# and the update to debian/changelog
-########
-
-mkdir -p debian/tmp
-(cd debian/tmp
- git clone "${UPSTREAM_REPO}" upstream || (rm -rf upstream; sleep 60; git clone "${UPSTREAM_REPO}" upstream)
- cd upstream
- $FETCH
- $CO
- git config user.email "$DUMMY_USER_EMAIL"
- git config user.name "$DUMMY_USER_NAME"
- if [ -n "${UPSTREAM_PULL_REQUEST:-}" ] && [ "${UPSTREAM_REPO}" != "https://github.com/systemd/systemd-stable.git" ]; then
- git rebase main
- fi
-)
-UPSTREAM_VER=$(cd debian/tmp/upstream; git describe | sed 's/^v//;s/-/./g')
-
# clean out original upstream sources
-find -mindepth 1 -maxdepth 1 -name debian -o -name .git -prune -o -print0 | xargs -0n1 rm -rf
+find . -mindepth 1 -maxdepth 1 -name debian -o -name .git -prune -o -print0 | xargs -0n1 rm -rf
# These options changes are only needed for the upstream CI, and we don't want to pollute d/rules with them.
# Also we want to ensure running on an older branch (e.g.: for the systemd-stable repository) doesn't break.
@@ -106,7 +111,7 @@ mv debian/tmp/upstream/* .
rm -rf debian/tmp
# create new git commit with upstream code
-if [ -d .git -a -n "$(git status --short)" ] ; then
+if [ -d .git ] && [ -n "$(git status --short)" ] ; then
git add .
git commit -n -m "checkout-upstream: replace with upstream code at version ${UPSTREAM_VER}"
fi
@@ -114,7 +119,7 @@ fi
# import Debian patches which apply cleanly
if [ -n "${KEEP_DEBIAN_PATCHES:-}" ]; then
for c in $(git log "$BRANCH_NAME"..patch-queue/"$BRANCH_NAME" --format='%H' --reverse); do
- if ! git cherry-pick $c; then
+ if ! git cherry-pick "$c"; then
git cherry-pick --abort
git reset --hard
git clean -dxf
diff --git a/debian/extra/initramfs-tools/hooks/udev b/debian/extra/initramfs-tools/hooks/udev
index 2ad482a..5a860e1 100755
--- a/debian/extra/initramfs-tools/hooks/udev
+++ b/debian/extra/initramfs-tools/hooks/udev
@@ -28,9 +28,9 @@ cp -p /etc/udev/udev.conf "$DESTDIR/etc/udev/"
# copy .link files containing interface naming definitions
mkdir -p "$DESTDIR/usr/lib/systemd/network/"
-find -L /usr/lib/systemd/network -name '*.link' -execdir cp -pt "$DESTDIR/usr/lib/systemd/network/" '{}' +
+find -L /usr/lib/systemd/network -name '*.link*' -execdir cp -r -pt "$DESTDIR/usr/lib/systemd/network/" '{}' +
if [ -d /etc/systemd/network ]; then
- find -L /etc/systemd/network -name '*.link' -execdir cp -pt "$DESTDIR/usr/lib/systemd/network/" '{}' +
+ find -L /etc/systemd/network -name '*.link*' -execdir cp -r -pt "$DESTDIR/usr/lib/systemd/network/" '{}' +
fi
mkdir -p "$DESTDIR/usr/lib/udev/rules.d/"
diff --git a/debian/not-installed b/debian/not-installed
index 324b31d..149dfb1 100644
--- a/debian/not-installed
+++ b/debian/not-installed
@@ -1,4 +1,4 @@
# make dh_missing happy for -A builds
usr/bin/systemd-sysusers.standalone
usr/bin/systemd-tmpfiles.standalone
-usr/bin/systemd-shutdown.standalone
+usr/lib/systemd/systemd-shutdown.standalone
diff --git a/debian/systemd-container.install b/debian/systemd-container.install
index f3badad..203ae2a 100755
--- a/debian/systemd-container.install
+++ b/debian/systemd-container.install
@@ -17,8 +17,11 @@ usr/lib/systemd/systemd-nsresourcework
usr/lib/systemd/systemd-portabled
usr/lib/systemd/systemd-pull
usr/lib/systemd/systemd-sysupdate
+<pkg.systemd.upstream> usr/lib/systemd/system-generators/systemd-import-generator
+<pkg.systemd.upstream> usr/lib/systemd/system/sockets.target.wants/systemd-importd.socket
usr/lib/systemd/system/systemd-nspawn@.service
usr/lib/systemd/system/systemd-importd.service
+<pkg.systemd.upstream> usr/lib/systemd/system/systemd-importd.socket
usr/lib/systemd/system/systemd-machined.service
usr/lib/systemd/system/systemd-mountfsd*
usr/lib/systemd/system/systemd-nsresourced*
diff --git a/debian/systemd-container.manpages b/debian/systemd-container.manpages
index a027942..8bf5780 100755
--- a/debian/systemd-container.manpages
+++ b/debian/systemd-container.manpages
@@ -9,6 +9,7 @@ debian/tmp/usr/share/man/man5/sysupdate.d.5
debian/tmp/usr/share/man/man1/machinectl.1
debian/tmp/usr/share/man/man1/portablectl.1
debian/tmp/usr/share/man/man1/systemd-dissect.1
+<pkg.systemd.upstream> debian/tmp/usr/share/man/man8/systemd-import-generator.8
debian/tmp/usr/share/man/man8/systemd-importd.8
debian/tmp/usr/share/man/man8/systemd-importd.service.8
debian/tmp/usr/share/man/man8/systemd-machined.8
diff --git a/debian/systemd.install b/debian/systemd.install
index b5e0854..df5f857 100755
--- a/debian/systemd.install
+++ b/debian/systemd.install
@@ -499,6 +499,7 @@ usr/share/zsh/vendor-completions/_kernel-install
usr/share/zsh/vendor-completions/_localectl
usr/share/zsh/vendor-completions/_loginctl
usr/share/zsh/vendor-completions/_networkctl
+usr/share/zsh/vendor-completions/_run0
usr/share/zsh/vendor-completions/_sd_hosts_or_user_at_host
usr/share/zsh/vendor-completions/_sd_outputmodes
usr/share/zsh/vendor-completions/_sd_unit_files
diff --git a/debian/tests/upstream b/debian/tests/upstream
index 6b7899a..3736f39 100755
--- a/debian/tests/upstream
+++ b/debian/tests/upstream
@@ -90,8 +90,9 @@ fi
sed -i "/depends : mkosi_depends/d" meson.build
# qemu/vsock does not appear to work on ppc64el/s390x, so skip those tests
+# qemu tests time out on arm64, so skip them
dpkgarch=$(dpkg --print-architecture)
-if [ "$dpkgarch" = ppc64el ] || [ "$dpkgarch" = s390x ]; then
+if [ "$dpkgarch" = ppc64el ] || [ "$dpkgarch" = s390x ] || [ "$dpkgarch" = arm64 ]; then
export TEST_NO_QEMU=1
fi