summaryrefslogtreecommitdiffstats
path: root/po/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /po/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'po/meson.build')
-rw-r--r--po/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/po/meson.build b/po/meson.build
new file mode 100644
index 0000000..0a140b4
--- /dev/null
+++ b/po/meson.build
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+want_translations = get_option('translations')
+
+if want_translations
+ i18n = import('i18n')
+ i18n.gettext(meson.project_name(),
+ preset : 'glib',
+ data_dirs : '.')
+endif