summaryrefslogtreecommitdiffstats
path: root/src/pstore/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/pstore/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pstore/meson.build')
-rw-r--r--src/pstore/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/pstore/meson.build b/src/pstore/meson.build
new file mode 100644
index 0000000..b6fda87
--- /dev/null
+++ b/src/pstore/meson.build
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ libexec_template + {
+ 'name' : 'systemd-pstore',
+ 'conditions' : ['ENABLE_PSTORE'],
+ 'sources' : files('pstore.c'),
+ 'dependencies' : [
+ libacl,
+ liblz4,
+ libxz,
+ libzstd,
+ threads,
+ ],
+ },
+]
+
+if conf.get('ENABLE_PSTORE') == 1 and install_sysconfdir_samples
+ install_data('pstore.conf',
+ install_dir : pkgconfigfiledir)
+endif