summaryrefslogtreecommitdiffstats
path: root/src/rpm/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /src/rpm/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/rpm/meson.build')
-rw-r--r--src/rpm/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/rpm/meson.build b/src/rpm/meson.build
new file mode 100644
index 0000000..af39ff1
--- /dev/null
+++ b/src/rpm/meson.build
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+in_files = [
+ ['macros.systemd', rpmmacrosdir != 'no', rpmmacrosdir],
+
+ # we conditionalize on rpmmacrosdir, but install into libexecdir
+ ['systemd-update-helper', rpmmacrosdir != 'no', libexecdir],
+
+ ['triggers.systemd', false],
+ ['triggers.systemd.sh', false]]
+
+# The last two don't get installed anywhere, one of them needs to included in
+# the rpm spec file definition instead.
+
+foreach tuple : in_files
+ file = tuple[0]
+ custom_target(
+ file,
+ input : file + '.in',
+ output : file,
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : tuple[1],
+ install_dir : tuple.length() > 2 ? tuple[2] : '',
+ build_by_default : true)
+endforeach