summaryrefslogtreecommitdiffstats
path: root/sysusers.d
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:42 +0000
commit78e9bb837c258ac0ec7712b3d612cc2f407e731e (patch)
treef515d16b6efd858a9aeb5b0ef5d6f90bf288283d /sysusers.d
parentAdding debian version 255.5-1. (diff)
downloadsystemd-78e9bb837c258ac0ec7712b3d612cc2f407e731e.tar.xz
systemd-78e9bb837c258ac0ec7712b3d612cc2f407e731e.zip
Merging upstream version 256.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sysusers.d')
-rw-r--r--sysusers.d/meson.build36
1 files changed, 13 insertions, 23 deletions
diff --git a/sysusers.d/meson.build b/sysusers.d/meson.build
index 608c4b7..4402b10 100644
--- a/sysusers.d/meson.build
+++ b/sysusers.d/meson.build
@@ -1,31 +1,21 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
-files = [['README', ''],
- ['systemd-coredump.conf', 'ENABLE_COREDUMP'],
- ['systemd-oom.conf', 'ENABLE_OOMD']]
+files = [['README', true],
+ ['systemd-coredump.conf', conf.get('ENABLE_COREDUMP') == 1],
+ ['systemd-oom.conf', conf.get('ENABLE_OOMD') == 1],
+ ['systemd-remote.conf', conf.get('ENABLE_REMOTE') == 1 and conf.get('HAVE_MICROHTTPD') == 1]]
-foreach pair : files
- if not enable_sysusers
- # do nothing
- elif pair[1] == '' or conf.get(pair[1]) == 1
- install_data(pair[0], install_dir : sysusersdir)
- else
- message('Not installing sysusers.d/@0@ because @1@ is @2@'
- .format(pair[0], pair[1], conf.get(pair[1], 0)))
+foreach tuple : files
+ if enable_sysusers and tuple[1]
+ install_data(tuple[0], install_dir : sysusersdir)
endif
endforeach
-
-if enable_sysusers and conf.get('ENABLE_REMOTE') == 1 and conf.get('HAVE_MICROHTTPD') == 1
- install_data('systemd-remote.conf', install_dir : sysusersdir)
-endif
-
-
-in_files = [['basic.conf', enable_sysusers],
- ['systemd-journal.conf', enable_sysusers],
- ['systemd-network.conf', enable_sysusers and conf.get('ENABLE_NETWORKD') == 1],
- ['systemd-resolve.conf', enable_sysusers and conf.get('ENABLE_RESOLVE') == 1],
- ['systemd-timesync.conf', enable_sysusers and conf.get('ENABLE_TIMESYNCD') == 1]]
+in_files = [['basic.conf', true],
+ ['systemd-journal.conf', true],
+ ['systemd-network.conf', conf.get('ENABLE_NETWORKD') == 1],
+ ['systemd-resolve.conf', conf.get('ENABLE_RESOLVE') == 1],
+ ['systemd-timesync.conf', conf.get('ENABLE_TIMESYNCD') == 1]]
foreach tuple : in_files
file = tuple[0]
@@ -34,6 +24,6 @@ foreach tuple : in_files
input : file + '.in',
output: file,
command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
- install : tuple[1],
+ install : enable_sysusers and tuple[1],
install_dir : sysusersdir)
endforeach