summaryrefslogtreecommitdiffstats
path: root/test/TEST-01-BASIC
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
commitfc53809803cd2bc2434e312b19a18fa36776da12 (patch)
treeb4b43bd6538f51965ce32856e9c053d0f90919c8 /test/TEST-01-BASIC
parentAdding upstream version 255.5. (diff)
downloadsystemd-fc53809803cd2bc2434e312b19a18fa36776da12.tar.xz
systemd-fc53809803cd2bc2434e312b19a18fa36776da12.zip
Adding upstream version 256.upstream/256
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-01-BASIC')
-rw-r--r--test/TEST-01-BASIC/meson.build7
-rwxr-xr-xtest/TEST-01-BASIC/test.sh10
2 files changed, 7 insertions, 10 deletions
diff --git a/test/TEST-01-BASIC/meson.build b/test/TEST-01-BASIC/meson.build
new file mode 100644
index 0000000..257dadd
--- /dev/null
+++ b/test/TEST-01-BASIC/meson.build
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+integration_tests += [
+ integration_test_template + {
+ 'name' : 'TEST-01-BASIC',
+ },
+]
diff --git a/test/TEST-01-BASIC/test.sh b/test/TEST-01-BASIC/test.sh
index 93185cf..d961973 100755
--- a/test/TEST-01-BASIC/test.sh
+++ b/test/TEST-01-BASIC/test.sh
@@ -16,14 +16,4 @@ KERNEL_APPEND="foo -- -z bar --- baz $KERNEL_APPEND"
# shellcheck source=test/test-functions
. "${TEST_BASE_DIR:?}/test-functions"
-test_append_files() {
- local workspace="${1:?}"
- local dst
-
- # Install tests manually so the test is functional even when -Dinstall-tests=false
- dst="$workspace/usr/lib/systemd/tests/testdata/units/"
- mkdir -p "$dst"
- cp -v "$TEST_UNITS_DIR"/{testsuite-01,end}.service "$TEST_UNITS_DIR/testsuite.target" "$dst"
-}
-
do_test "$@"