summaryrefslogtreecommitdiffstats
path: root/test/TEST-55-OOMD
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:20:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-16 18:20:20 +0000
commit8612d3d858fa108e5732a586d4e2d0227ae34422 (patch)
tree33e7f8b3d5caa6c44b4d6759cb25d3eff4b2d975 /test/TEST-55-OOMD
parentAdding debian version 256.2-1. (diff)
downloadsystemd-8612d3d858fa108e5732a586d4e2d0227ae34422.tar.xz
systemd-8612d3d858fa108e5732a586d4e2d0227ae34422.zip
Merging upstream version 256.4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-55-OOMD')
-rw-r--r--test/TEST-55-OOMD/meson.build3
-rwxr-xr-xtest/TEST-55-OOMD/test.sh2
2 files changed, 4 insertions, 1 deletions
diff --git a/test/TEST-55-OOMD/meson.build b/test/TEST-55-OOMD/meson.build
index adc0509..2566316 100644
--- a/test/TEST-55-OOMD/meson.build
+++ b/test/TEST-55-OOMD/meson.build
@@ -5,6 +5,9 @@ integration_tests += [
'name' : fs.name(meson.current_source_dir()),
'credentials' : integration_test_template['credentials'] + [
files('systemd.unit-dropin.init.scope'),
+ # OpenSUSE disables all controller delegation for the user manager template. Mask the
+ # dropin to make TEST-55-OOMD pass on OpenSUSE.
+ 'systemd.unit-dropin.user@.service~20-defaults-SUSE=',
],
'vm' : true,
},
diff --git a/test/TEST-55-OOMD/test.sh b/test/TEST-55-OOMD/test.sh
index 5e30963..3b2f471 100755
--- a/test/TEST-55-OOMD/test.sh
+++ b/test/TEST-55-OOMD/test.sh
@@ -14,7 +14,7 @@ TEST_NO_NSPAWN=1
test_append_files() {
local workspace="${1:?}"
- image_install mkswap swapon swapoff stress
+ image_install mkswap swapon swapoff stress-ng
image_install -o btrfs
mkdir -p "${workspace:?}/etc/systemd/system/init.scope.d/"