summaryrefslogtreecommitdiffstats
path: root/test/TEST-64-UDEV-STORAGE/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
commitfc53809803cd2bc2434e312b19a18fa36776da12 (patch)
treeb4b43bd6538f51965ce32856e9c053d0f90919c8 /test/TEST-64-UDEV-STORAGE/meson.build
parentAdding upstream version 255.5. (diff)
downloadsystemd-fc53809803cd2bc2434e312b19a18fa36776da12.tar.xz
systemd-fc53809803cd2bc2434e312b19a18fa36776da12.zip
Adding upstream version 256.upstream/256
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-64-UDEV-STORAGE/meson.build')
-rw-r--r--test/TEST-64-UDEV-STORAGE/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/test/TEST-64-UDEV-STORAGE/meson.build b/test/TEST-64-UDEV-STORAGE/meson.build
new file mode 100644
index 0000000..15981ce
--- /dev/null
+++ b/test/TEST-64-UDEV-STORAGE/meson.build
@@ -0,0 +1,43 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+name = fs.name(meson.current_source_dir())
+unit = configure_file(
+ input : files('../test.service.in'),
+ output : '@0@.service'.format(name),
+ # Disable user service manager by default for performance.
+ configuration : integration_test_template['configuration'] + {
+ 'wants' : '',
+ 'after' : '',
+ },
+)
+
+foreach testcase : [
+ 'btrfs_basic',
+ 'iscsi_lvm',
+ 'long_sysfs_path',
+ 'lvm_basic',
+ 'mdadm_basic',
+ 'mdadm_lvm',
+ 'multipath_basic_failover',
+ 'nvme_basic',
+ 'nvme_subsystem',
+ 'simultaneous_events',
+ 'virtio_scsi_basic',
+ 'virtio_scsi_identically_named_partitions',
+]
+ integration_tests += [
+ integration_test_template + {
+ 'name' : '@0@-@1@'.format(name, testcase),
+ # Make sure the service is still named TEST-64-UDEV-STORAGE.service.
+ 'unit' : unit,
+ 'cmdline' : integration_test_template['cmdline'] + [
+ 'systemd.setenv=TEST_FUNCTION_NAME=testcase_@0@'.format(testcase)
+ ],
+ 'mkosi-args' : integration_test_template['mkosi-args'] + [
+ '--configure-script', files('@0@.configure'.format(testcase)),
+ ],
+ 'priority' : 10,
+ 'vm' : true,
+ },
+ ]
+endforeach