summaryrefslogtreecommitdiffstats
path: root/test/TEST-75-RESOLVED
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
commitfc53809803cd2bc2434e312b19a18fa36776da12 (patch)
treeb4b43bd6538f51965ce32856e9c053d0f90919c8 /test/TEST-75-RESOLVED
parentAdding upstream version 255.5. (diff)
downloadsystemd-fc53809803cd2bc2434e312b19a18fa36776da12.tar.xz
systemd-fc53809803cd2bc2434e312b19a18fa36776da12.zip
Adding upstream version 256.upstream/256
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-75-RESOLVED')
-rw-r--r--test/TEST-75-RESOLVED/meson.build7
-rwxr-xr-xtest/TEST-75-RESOLVED/test.sh15
2 files changed, 7 insertions, 15 deletions
diff --git a/test/TEST-75-RESOLVED/meson.build b/test/TEST-75-RESOLVED/meson.build
new file mode 100644
index 0000000..8dec5f3
--- /dev/null
+++ b/test/TEST-75-RESOLVED/meson.build
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+integration_tests += [
+ integration_test_template + {
+ 'name' : fs.name(meson.current_source_dir()),
+ },
+]
diff --git a/test/TEST-75-RESOLVED/test.sh b/test/TEST-75-RESOLVED/test.sh
index 55a9f1b..6272d5a 100755
--- a/test/TEST-75-RESOLVED/test.sh
+++ b/test/TEST-75-RESOLVED/test.sh
@@ -11,14 +11,7 @@ NSPAWN_ARGUMENTS="--private-network"
test_require_bin knotd
-# We need at least Knot 3.0 which support (among others) the ds-push directive
-if ! knotc -c "${TEST_BASE_DIR:?}/knot-data/knot.conf" conf-check; then
- echo "This test requires at least Knot 3.0. skipping..."
- exit 0
-fi
-
test_append_files() {
- local workspace="${1:?}"
# Install knot
image_install kzonecheck keymgr kjournalprint knotc knotd
image_install "${ROOTLIBDIR:?}/system/knot.service"
@@ -26,14 +19,6 @@ test_append_files() {
image_install -o /etc/dbus-1/system.d/cz.nic.knotd.conf
image_install -o /etc/default/knot
- # Copy over our configuration
- mkdir -p "${workspace:?}/var/lib/knot/zones/" "${workspace:?}/etc/knot/"
- cp -rfv "${TEST_BASE_DIR:?}"/knot-data/zones/* "$workspace/var/lib/knot/zones/"
- cp -fv "${TEST_BASE_DIR:?}/knot-data/knot.conf" "$workspace/etc/knot/knot.conf"
- chgrp -R knot "$workspace/etc/knot/" "$workspace/var/lib/knot/"
- chmod -R ug+rwX "$workspace/var/lib/knot/"
- chmod -R g+r "$workspace/etc/knot/"
-
# Install DNS-related utilities (usually found in the bind-utils package)
image_install delv dig host nslookup