summaryrefslogtreecommitdiffstats
path: root/units/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 03:50:40 +0000
commitfc53809803cd2bc2434e312b19a18fa36776da12 (patch)
treeb4b43bd6538f51965ce32856e9c053d0f90919c8 /units/meson.build
parentAdding upstream version 255.5. (diff)
downloadsystemd-fc53809803cd2bc2434e312b19a18fa36776da12.tar.xz
systemd-fc53809803cd2bc2434e312b19a18fa36776da12.zip
Adding upstream version 256.upstream/256
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build81
1 files changed, 78 insertions, 3 deletions
diff --git a/units/meson.build b/units/meson.build
index e7bfb7f..b231341 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -7,6 +7,8 @@ units = [
{ 'file' : 'blockdev@.target' },
{ 'file' : 'bluetooth.target' },
{ 'file' : 'boot-complete.target' },
+ { 'file' : 'capsule@.service.in' },
+ { 'file' : 'capsule.slice' },
{ 'file' : 'console-getty.service.in' },
{ 'file' : 'container-getty@.service.in' },
{
@@ -161,7 +163,11 @@ units = [
'conditions' : ['ENABLE_BINFMT'],
},
{
- 'file' : 'quotaon.service.in',
+ 'file' : 'quotaon@.service.in',
+ 'conditions' : ['ENABLE_QUOTACHECK'],
+ },
+ {
+ 'file' : 'quotaon-root.service.in',
'conditions' : ['ENABLE_QUOTACHECK'],
},
{
@@ -199,6 +205,7 @@ units = [
{ 'file' : 'sockets.target' },
{ 'file' : 'soft-reboot.target' },
{ 'file' : 'sound.target' },
+ { 'file' : 'ssh-access.target' },
{
'file' : 'suspend-then-hibernate.target',
'conditions' : ['ENABLE_HIBERNATE'],
@@ -268,6 +275,15 @@ units = [
'conditions' : ['ENABLE_BOOTLOADER'],
},
{
+ 'file' : 'systemd-bootctl@.service',
+ 'conditions' : ['ENABLE_BOOTLOADER'],
+ },
+ {
+ 'file' : 'systemd-bootctl.socket',
+ 'conditions' : ['ENABLE_BOOTLOADER'],
+ 'symlinks' : ['sockets.target.wants/'],
+ },
+ {
'file' : 'systemd-confext.service',
'conditions' : ['ENABLE_SYSEXT'],
},
@@ -280,6 +296,11 @@ units = [
'file' : 'systemd-coredump@.service.in',
'conditions' : ['ENABLE_COREDUMP'],
},
+ {
+ 'file' : 'systemd-creds.socket',
+ 'symlinks' : ['sockets.target.wants/'],
+ },
+ { 'file' : 'systemd-creds@.service' },
{ 'file' : 'systemd-exit.service' },
{
'file' : 'systemd-firstboot.service',
@@ -292,6 +313,11 @@ units = [
{ 'file' : 'systemd-growfs@.service.in' },
{ 'file' : 'systemd-halt.service' },
{
+ 'file' : 'systemd-hibernate-clear.service.in',
+ 'conditions' : ['ENABLE_HIBERNATE', 'ENABLE_EFI'],
+ 'symlinks' : ['sysinit.target.wants/'],
+ },
+ {
'file' : 'systemd-hibernate-resume.service.in',
'conditions' : ['ENABLE_HIBERNATE'],
},
@@ -304,6 +330,10 @@ units = [
'conditions' : ['ENABLE_HOMED'],
},
{
+ 'file' : 'systemd-homed-firstboot.service',
+ 'conditions' : ['ENABLE_HOMED'],
+ },
+ {
'file' : 'systemd-homed.service.in',
'conditions' : ['ENABLE_HOMED'],
},
@@ -313,6 +343,11 @@ units = [
'symlinks' : ['dbus-org.freedesktop.hostname1.service'],
},
{
+ 'file' : 'systemd-hostnamed.socket',
+ 'conditions' : ['ENABLE_HOSTNAMED'],
+ 'symlinks' : ['sockets.target.wants/'],
+ },
+ {
'file' : 'systemd-hwdb-update.service.in',
'conditions' : ['ENABLE_HWDB'],
'symlinks' : ['sysinit.target.wants/'],
@@ -368,6 +403,7 @@ units = [
'file' : 'systemd-journald-dev-log.socket',
'symlinks' : ['sockets.target.wants/'],
},
+ { 'file' : 'systemd-journald-sync@.service' },
{ 'file' : 'systemd-journald-varlink@.socket' },
{
'file' : 'systemd-journald.service.in',
@@ -406,6 +442,10 @@ units = [
},
{ 'file' : 'systemd-network-generator.service.in' },
{
+ 'file' : 'systemd-networkd-persistent-storage.service',
+ 'conditions' : ['ENABLE_NETWORKD'],
+ },
+ {
'file' : 'systemd-networkd-wait-online.service.in',
'conditions' : ['ENABLE_NETWORKD'],
},
@@ -423,6 +463,10 @@ units = [
},
{ 'file' : 'systemd-nspawn@.service.in' },
{
+ 'file' : 'systemd-vmspawn@.service.in',
+ 'conditions' : ['ENABLE_VMSPAWN'],
+ },
+ {
'file' : 'systemd-oomd.service.in',
'conditions' : ['ENABLE_OOMD'],
},
@@ -506,6 +550,15 @@ units = [
'conditions' : ['ENABLE_BOOTLOADER', 'HAVE_OPENSSL', 'HAVE_TPM2'],
},
{
+ 'file' : 'systemd-pcrlock@.service.in',
+ 'conditions' : ['ENABLE_BOOTLOADER', 'HAVE_OPENSSL', 'HAVE_TPM2'],
+ },
+ {
+ 'file' : 'systemd-pcrlock.socket',
+ 'conditions' : ['ENABLE_BOOTLOADER', 'HAVE_OPENSSL', 'HAVE_TPM2'],
+ 'symlinks' : ['sockets.target.wants/'],
+ },
+ {
'file' : 'systemd-portabled.service.in',
'conditions' : ['ENABLE_PORTABLED'],
'symlinks' : ['dbus-org.freedesktop.portable1.service'],
@@ -516,7 +569,11 @@ units = [
'conditions' : ['ENABLE_PSTORE'],
},
{
- 'file' : 'systemd-quotacheck.service.in',
+ 'file' : 'systemd-quotacheck@.service.in',
+ 'conditions' : ['ENABLE_QUOTACHECK'],
+ },
+ {
+ 'file' : 'systemd-quotacheck-root.service.in',
'conditions' : ['ENABLE_QUOTACHECK'],
},
{
@@ -527,7 +584,7 @@ units = [
{ 'file' : 'systemd-reboot.service' },
{ 'file' : 'systemd-remount-fs.service.in' },
{
- 'file' : 'systemd-repart.service.in',
+ 'file' : 'systemd-repart.service',
'conditions' : ['ENABLE_REPART'],
'symlinks' : ['sysinit.target.wants/', 'initrd-root-fs.target.wants/'],
},
@@ -632,6 +689,7 @@ units = [
'conditions' : ['ENABLE_TMPFILES'],
'symlinks' : ['sysinit.target.wants/'],
},
+ { 'file' : 'systemd-udev-load-credentials.service' },
{ 'file' : 'systemd-udev-settle.service' },
{
'file' : 'systemd-udev-trigger.service',
@@ -677,6 +735,22 @@ units = [
'conditions' : ['ENABLE_USERDB'],
},
{
+ 'file' : 'systemd-mountfsd.service.in',
+ 'conditions' : ['ENABLE_MOUNTFSD'],
+ },
+ {
+ 'file' : 'systemd-mountfsd.socket',
+ 'conditions' : ['ENABLE_MOUNTFSD'],
+ },
+ {
+ 'file' : 'systemd-nsresourced.service.in',
+ 'conditions' : ['ENABLE_NSRESOURCED'],
+ },
+ {
+ 'file' : 'systemd-nsresourced.socket',
+ 'conditions' : ['ENABLE_NSRESOURCED'],
+ },
+ {
'file' : 'systemd-vconsole-setup.service.in',
'conditions' : ['ENABLE_VCONSOLE'],
},
@@ -691,6 +765,7 @@ units = [
'file' : 'tmp.mount',
'symlinks' : ['local-fs.target.wants/'],
},
+ { 'file' : 'tpm2.target' },
{ 'file' : 'umount.target' },
{ 'file' : 'usb-gadget.target' },
{ 'file' : 'user-runtime-dir@.service.in' },