summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/NEWS11
-rw-r--r--debian/changelog18
-rwxr-xr-xdebian/extra/initramfs-tools/hooks/udev20
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/salsa-ci.yml7
-rwxr-xr-xdebian/systemd.install7
-rwxr-xr-xdebian/systemd.manpages3
7 files changed, 65 insertions, 2 deletions
diff --git a/debian/NEWS b/debian/NEWS
index 930fe71..6d491b7 100644
--- a/debian/NEWS
+++ b/debian/NEWS
@@ -1,3 +1,14 @@
+systemd (256-2) unstable; urgency=medium
+
+ cryptsetup tools such as systemd-cryptsetup, systemd-cryptenroll,
+ systemd-veritysetup, and more, have been split into a new systemd-cryptsetup
+ package to reduce dependencies pulled in by the main systemd package. This
+ new package is only listed as a Recommends, so if this functionality is used
+ ensure that either Recommends are installed (default) or that it is
+ manually installed.
+
+ -- Luca Boccassi <bluca@debian.org> Tue, 10 Sep 2024 18:19:16 +0200
+
systemd (256~rc3-3) unstable; urgency=medium
- /tmp/ is now by default a tmpfs, via the tmp.mount unit provided upstream.
diff --git a/debian/changelog b/debian/changelog
index 711b915..5db0592 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+systemd (256.6-1) unstable; urgency=medium
+
+ [ Helmut Grohne ]
+ * salsa-ci: test the stage1 build profile
+
+ [ Simon Chopin ]
+ * Filter out zdev rules in the initramfs hook (LP: #2044104). s390-tools
+ has its own initramfs customization logic that deals with those files.
+
+ [ Luca Boccassi ]
+ * Re-enable utmp support, tmux's autopkgtests require it. This will
+ break as logind writing into utmp will wrap around, so Trixie won't be
+ y2038 ready after all
+ * New upstream version 256.6
+ * Note systemd-cryptsetup package split in NEWS (Closes: #1079644)
+
+ -- Luca Boccassi <bluca@debian.org> Tue, 10 Sep 2024 18:28:21 +0200
+
systemd (256.5-2) unstable; urgency=medium
[ Helmut Grohne ]
diff --git a/debian/extra/initramfs-tools/hooks/udev b/debian/extra/initramfs-tools/hooks/udev
index 5a860e1..06f3c5e 100755
--- a/debian/extra/initramfs-tools/hooks/udev
+++ b/debian/extra/initramfs-tools/hooks/udev
@@ -46,11 +46,29 @@ for rules in 50-firmware.rules 50-udev-default.rules \
fi
done
+# See if chzdev can filter out generated rules, per LP: #2044104
+ZDEV_FILTERING=0
+if [ -e /usr/sbin/chzdev ] && \
+ dpkg --compare-versions "$(dpkg-query -f '${Version}' -W s390-tools 2> /dev/null)" '>=' '2.33.0';
+then
+ ZDEV_FILTERING=1
+fi
+
# now copy all custom udev rules which don't have an equivalent in /usr/lib (e. g.
# 70-persistent-net.rules or similar); They might contain network names or
# other bits which are relevant for the initramfs.
for rules in /etc/udev/rules.d/*.rules; do
- if [ -e "$rules" ] && [ ! -e "/usr/lib/${rules#/etc/}" ]; then
+ if [ ! -e "$rules" ]; then
+ continue
+ fi
+
+ # Skip rules generated by chzdev as they are handled by its own hook.
+ # See LP: #2044104
+ if [ $ZDEV_FILTERING -eq 1 ] && /usr/sbin/chzdev --is-owner "$rules"; then
+ continue;
+ fi
+
+ if [ ! -e "/usr/lib/${rules#/etc/}" ]; then
cp -p "$rules" "$DESTDIR/usr/lib/udev/rules.d/"
fi
done
diff --git a/debian/rules b/debian/rules
index 3ef58a8..e690ce8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -111,7 +111,6 @@ CONFFLAGS = \
-Dresolve=true \
-Dstatus-unit-format-default=combined \
-Dstandalone-binaries=true \
- -Dutmp=false \
-Dmode=$(if $(filter pkg.systemd.upstream,$(DEB_BUILD_PROFILES)),developer,release)
ifeq ($(filter nocheck,$(DEB_BUILD_PROFILES))$(filter noinsttest,$(DEB_BUILD_PROFILES)),nochecknoinsttest)
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
index 025c0ae..3c6cd7c 100644
--- a/debian/salsa-ci.yml
+++ b/debian/salsa-ci.yml
@@ -5,3 +5,10 @@ include:
variables:
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1011649
SALSA_CI_DISABLE_PIUPARTS: 1
+ SALSA_CI_ENABLE_BUILD_PACKAGE_PROFILES: 1
+
+test-build-profiles:
+ extends: .test-build-package-profiles
+ parallel:
+ matrix:
+ - BUILD_PROFILES: nocheck,stage1
diff --git a/debian/systemd.install b/debian/systemd.install
index 91c72cf..927e9f9 100755
--- a/debian/systemd.install
+++ b/debian/systemd.install
@@ -140,6 +140,7 @@ usr/lib/systemd/systemd-sysroot-fstab-check
usr/lib/systemd/systemd-timedated
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/systemd-tpm2-setup
usr/lib/systemd/systemd-update-done
+usr/lib/systemd/systemd-update-utmp
usr/lib/systemd/systemd-user-runtime-dir
usr/lib/systemd/systemd-user-sessions
usr/lib/systemd/systemd-volatile-root
@@ -165,6 +166,7 @@ usr/lib/systemd/system/getty-pre.target
usr/lib/systemd/system/getty@.service
usr/lib/systemd/system/getty.target
usr/lib/systemd/system/graphical.target
+usr/lib/systemd/system/graphical.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/halt.target
usr/lib/systemd/system/hibernate.target
usr/lib/systemd/system/hybrid-sleep.target
@@ -193,6 +195,7 @@ usr/lib/systemd/system/multi-user.target
usr/lib/systemd/system/multi-user.target.wants/getty.target
usr/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
usr/lib/systemd/system/multi-user.target.wants/systemd-logind.service
+usr/lib/systemd/system/multi-user.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/multi-user.target.wants/systemd-user-sessions.service
usr/lib/systemd/system/network-online.target
usr/lib/systemd/system/network-pre.target
@@ -212,6 +215,7 @@ usr/lib/systemd/system/remote-fs-pre.target
usr/lib/systemd/system/remote-fs.target
usr/lib/systemd/system/rescue.service
usr/lib/systemd/system/rescue.target
+usr/lib/systemd/system/rescue.target.wants/systemd-update-utmp-runlevel.service
usr/lib/systemd/system/rpcbind.target
usr/lib/systemd/system/runlevel0.target
usr/lib/systemd/system/runlevel1.target
@@ -274,6 +278,7 @@ usr/lib/systemd/system/sysinit.target.wants/systemd-tmpfiles-setup.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sysinit.target.wants/systemd-tpm2-setup-early.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/sysinit.target.wants/systemd-tpm2-setup.service
usr/lib/systemd/system/sysinit.target.wants/systemd-update-done.service
+usr/lib/systemd/system/sysinit.target.wants/systemd-update-utmp.service
usr/lib/systemd/system/sys-kernel-config.mount
usr/lib/systemd/system/sys-kernel-debug.mount
usr/lib/systemd/system/sys-kernel-tracing.mount
@@ -366,6 +371,8 @@ usr/lib/systemd/system/systemd-tmpfiles-setup.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-tpm2-setup-early.service
[amd64 i386 arm64 armhf riscv64] <!stage1> usr/lib/systemd/system/systemd-tpm2-setup.service
usr/lib/systemd/system/systemd-update-done.service
+usr/lib/systemd/system/systemd-update-utmp-runlevel.service
+usr/lib/systemd/system/systemd-update-utmp.service
usr/lib/systemd/system/systemd-user-sessions.service
usr/lib/systemd/system/systemd-volatile-root.service
usr/lib/systemd/system/system-update-cleanup.service
diff --git a/debian/systemd.manpages b/debian/systemd.manpages
index f2f2a27..8027bee 100755
--- a/debian/systemd.manpages
+++ b/debian/systemd.manpages
@@ -253,6 +253,9 @@ debian/tmp/usr/share/man/man8/systemd-tpm2-generator.8
debian/tmp/usr/share/man/man8/systemd-udev-settle.service.8
debian/tmp/usr/share/man/man8/systemd-update-done.8
debian/tmp/usr/share/man/man8/systemd-update-done.service.8
+debian/tmp/usr/share/man/man8/systemd-update-utmp.8
+debian/tmp/usr/share/man/man8/systemd-update-utmp-runlevel.service.8
+debian/tmp/usr/share/man/man8/systemd-update-utmp.service.8
debian/tmp/usr/share/man/man8/systemd-user-sessions.8
debian/tmp/usr/share/man/man8/systemd-user-sessions.service.8
debian/tmp/usr/share/man/man8/systemd-volatile-root.8