summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 517d581..3ef58a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -111,6 +111,7 @@ CONFFLAGS = \
-Dresolve=true \
-Dstatus-unit-format-default=combined \
-Dstandalone-binaries=true \
+ -Dutmp=false \
-Dmode=$(if $(filter pkg.systemd.upstream,$(DEB_BUILD_PROFILES)),developer,release)
ifeq ($(filter nocheck,$(DEB_BUILD_PROFILES))$(filter noinsttest,$(DEB_BUILD_PROFILES)),nochecknoinsttest)
@@ -252,7 +253,7 @@ ifeq ($(DEB_VENDOR),Ubuntu)
cp -a debian/extra/units-ubuntu/* debian/systemd/usr/lib/systemd/system/
endif
-ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
+ifeq (,$(filter stage1 pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
ifeq ($(DEB_VENDOR),Debian)
ifneq ($(TEMPLATE_EFI_ARCH),)
debian/extra/gen-signing-template $(DEB_VERSION) $(DEB_HOST_ARCH) $(TEMPLATE_EFI_ARCH)