summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 8 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index b1a110c..0548e2e 100644
--- a/meson.build
+++ b/meson.build
@@ -1102,6 +1102,9 @@ else
# Check if 'clang -target bpf' is supported.
clang_supports_bpf = run_command(clang, '-target', 'bpf', '--print-supported-cpus', check : false).returncode() == 0
endif
+ if bpf_framework.enabled() and not clang_supports_bpf
+ error('bpf-framework was enabled but clang does not support bpf')
+ endif
elif bpf_compiler == 'gcc'
bpf_gcc = find_program('bpf-gcc',
'bpf-none-gcc',
@@ -1992,14 +1995,11 @@ endif
conf.set_quoted('VERSION_TAG', version_tag)
vcs_tag = get_option('vcs-tag')
-command = ['sh', '-c',
- vcs_tag and fs.exists(project_source_root / '.git') ?
- 'echo "-g$(git -C . describe --abbrev=7 --match="" --always --dirty=^)"' : ':']
version_h = vcs_tag(
input : 'src/version/version.h.in',
output : 'version.h',
fallback : '',
- command : command,
+ command : [vcs_tag ? 'tools/vcs-tag.sh' : 'true', get_option('mode')],
)
shared_lib_tag = get_option('shared-lib-tag')
@@ -2089,7 +2089,7 @@ libsystemd = shared_library(
# Make sure our library is never deleted from memory, so that our open logging fds don't leak on dlopen/dlclose cycles.
'-z', 'nodelete',
'-Wl,--version-script=' + libsystemd_sym_path],
- link_with : [libbasic],
+ link_with : [libbasic_static],
link_whole : [libsystemd_static],
dependencies : [librt,
threads,
@@ -2254,7 +2254,7 @@ nss_template = {
'link_with' : [
libsystemd_static,
libshared_static,
- libbasic,
+ libbasic_static,
],
'dependencies' : [
librt,
@@ -2660,12 +2660,6 @@ foreach executable : ['systemd-journal-remote', 'systemd-measure']
endforeach
if mkosi.found()
- genkey = custom_target('genkey',
- output : ['mkosi.key', 'mkosi.crt'],
- command : [mkosi, '--force', 'genkey'],
- depends : mkosi_depends,
- )
-
custom_target('mkosi',
build_always_stale : true,
build_by_default: false,
@@ -2677,14 +2671,11 @@ if mkosi.found()
'--output-dir', meson.current_build_dir() / 'mkosi.output',
'--cache-dir', meson.current_build_dir() / 'mkosi.cache',
'--build-dir', meson.current_build_dir() / 'mkosi.builddir',
- '--secure-boot-key', meson.current_build_dir() / 'mkosi.key',
- '--secure-boot-certificate', meson.current_build_dir() / 'mkosi.crt',
- '--verity-key', meson.current_build_dir() / 'mkosi.key',
- '--verity-certificate', meson.current_build_dir() / 'mkosi.crt',
+ '--extra-search-path', meson.current_build_dir(),
'--force',
'build',
],
- depends : mkosi_depends + [genkey],
+ depends : mkosi_depends,
)
endif