summaryrefslogtreecommitdiffstats
path: root/src/boot/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/boot/meson.build69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/boot/meson.build b/src/boot/meson.build
new file mode 100644
index 0000000..55b9bd6
--- /dev/null
+++ b/src/boot/meson.build
@@ -0,0 +1,69 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+bootctl_sources = files(
+ 'bootctl-install.c',
+ 'bootctl-random-seed.c',
+ 'bootctl-reboot-to-firmware.c',
+ 'bootctl-set-efivar.c',
+ 'bootctl-status.c',
+ 'bootctl-systemd-efi-options.c',
+ 'bootctl-uki.c',
+ 'bootctl-util.c',
+ 'bootctl.c',
+)
+
+if get_option('link-boot-shared')
+ boot_link_with = [libshared]
+else
+ boot_link_with = [
+ libshared_static,
+ libsystemd_static,
+ ]
+endif
+
+executables += [
+ executable_template + {
+ 'name' : 'bootctl',
+ 'public' : true,
+ 'conditions' : [
+ 'HAVE_BLKID',
+ ],
+ 'sources' : bootctl_sources,
+ 'link_with' : boot_link_with,
+ 'dependencies' : libblkid,
+ },
+ libexec_template + {
+ 'name' : 'systemd-bless-boot',
+ 'public' : true,
+ 'conditions' : [
+ 'HAVE_BLKID',
+ 'ENABLE_BOOTLOADER',
+ ],
+ 'sources' : files('bless-boot.c'),
+ 'link_with' : boot_link_with,
+ 'dependencies' : libblkid,
+ },
+ generator_template + {
+ 'name' : 'systemd-bless-boot-generator',
+ 'conditions' : [
+ 'HAVE_BLKID',
+ 'ENABLE_BOOTLOADER',
+ ],
+ 'sources' : files('bless-boot-generator.c'),
+ 'link_with' : boot_link_with,
+ },
+ libexec_template + {
+ 'name' : 'systemd-measure',
+ 'conditions' : [
+ 'HAVE_BLKID',
+ 'HAVE_OPENSSL',
+ 'HAVE_TPM2',
+ ],
+ 'sources' : files('measure.c'),
+ 'dependencies' : libopenssl,
+ },
+ libexec_template + {
+ 'name' : 'systemd-boot-check-no-failures',
+ 'sources' : files('boot-check-no-failures.c'),
+ },
+]