summaryrefslogtreecommitdiffstats
path: root/src/creds/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/creds/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/creds/meson.build b/src/creds/meson.build
new file mode 100644
index 0000000..8557256
--- /dev/null
+++ b/src/creds/meson.build
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+executables += [
+ executable_template + {
+ 'name' : 'systemd-creds',
+ 'public' : true,
+ 'sources' : files('creds.c'),
+ 'dependencies' : [
+ libopenssl,
+ threads,
+ ],
+ },
+]
+
+# Protecting files from the distro in /usr doesn't make sense since they can be trivially accessed otherwise,
+# so don't restrict the access mode in /usr. That doesn't apply to /etc, so we do restrict the access mode
+# there.
+install_emptydir(credstoredir)
+if install_sysconfdir
+ # Keep in sync with tmpfiles.d/credstore.conf
+ install_emptydir(sysconfdir / 'credstore',
+ install_mode : 'rwx------')
+ install_emptydir(sysconfdir / 'credstore.encrypted',
+ install_mode : 'rwx------')
+endif