summaryrefslogtreecommitdiffstats
path: root/src/cryptenroll/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/cryptenroll/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/cryptenroll/meson.build b/src/cryptenroll/meson.build
new file mode 100644
index 0000000..5374d65
--- /dev/null
+++ b/src/cryptenroll/meson.build
@@ -0,0 +1,36 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+systemd_cryptenroll_sources = files(
+ 'cryptenroll-list.c',
+ 'cryptenroll-password.c',
+ 'cryptenroll-recovery.c',
+ 'cryptenroll-wipe.c',
+ 'cryptenroll.c',
+)
+
+if conf.get('HAVE_P11KIT') == 1 and conf.get('HAVE_OPENSSL') == 1
+ systemd_cryptenroll_sources += files('cryptenroll-pkcs11.c')
+endif
+
+if conf.get('HAVE_LIBFIDO2') == 1
+ systemd_cryptenroll_sources += files('cryptenroll-fido2.c')
+endif
+
+if conf.get('HAVE_TPM2') == 1
+ systemd_cryptenroll_sources += files('cryptenroll-tpm2.c')
+endif
+
+executables += [
+ executable_template + {
+ 'name' : 'systemd-cryptenroll',
+ 'public' : true,
+ 'conditions' : ['HAVE_LIBCRYPTSETUP'],
+ 'sources' : systemd_cryptenroll_sources,
+ 'dependencies' : [
+ libcryptsetup,
+ libdl,
+ libopenssl,
+ libp11kit_cflags,
+ ],
+ },
+]