summaryrefslogtreecommitdiffstats
path: root/src/systemctl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/systemctl/meson.build')
-rw-r--r--src/systemctl/meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/systemctl/meson.build b/src/systemctl/meson.build
index 255c639..88f73bf 100644
--- a/src/systemctl/meson.build
+++ b/src/systemctl/meson.build
@@ -44,8 +44,7 @@ if get_option('link-systemctl-shared')
systemctl_link_with = [libshared]
else
systemctl_link_with = [libsystemd_static,
- libshared_static,
- libbasic_gcrypt]
+ libshared_static]
endif
executables += [
@@ -56,10 +55,10 @@ executables += [
'link_with' : systemctl_link_with,
'dependencies' : [
libcap,
- liblz4,
+ liblz4_cflags,
libselinux,
- libxz,
- libzstd,
+ libxz_cflags,
+ libzstd_cflags,
threads,
],
},