summaryrefslogtreecommitdiffstats
path: root/src/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/test/meson.build52
1 files changed, 36 insertions, 16 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index cce90d7..3abbb94 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -14,7 +14,7 @@ test_env = environment()
test_env.set('SYSTEMD_LANGUAGE_FALLBACK_MAP', language_fallback_map)
test_env.set('PATH', project_build_root + ':' + path)
test_env.set('PROJECT_BUILD_ROOT', project_build_root)
-test_env.set('SYSTEMD_SLOW_TESTS', slow_tests ? '1' : '0')
+test_env.set('SYSTEMD_SLOW_TESTS', want_slow_tests ? '1' : '0')
if efi_addon != ''
test_env.set('EFI_ADDON', efi_addon)
@@ -51,6 +51,7 @@ simple_tests += files(
'test-bitmap.c',
'test-blockdev-util.c',
'test-bootspec.c',
+ 'test-build-path.c',
'test-bus-util.c',
'test-calendarspec.c',
'test-cgroup-setup.c',
@@ -58,6 +59,7 @@ simple_tests += files(
'test-cgroup.c',
'test-chase.c',
'test-clock.c',
+ 'test-color-util.c',
'test-compare-operator.c',
'test-condition.c',
'test-conf-files.c',
@@ -72,6 +74,7 @@ simple_tests += files(
'test-dev-setup.c',
'test-device-nodes.c',
'test-devnum-util.c',
+ 'test-dirent-util.c',
'test-dns-domain.c',
'test-ellipsize.c',
'test-env-file.c',
@@ -107,8 +110,10 @@ simple_tests += files(
'test-install-file.c',
'test-install-root.c',
'test-io-util.c',
+ 'test-iovec-util.c',
'test-journal-importer.c',
'test-kbd-util.c',
+ 'test-label.c',
'test-limits-util.c',
'test-list.c',
'test-local-addresses.c',
@@ -116,6 +121,7 @@ simple_tests += files(
'test-lock-util.c',
'test-log.c',
'test-logarithm.c',
+ 'test-login-util.c',
'test-macro.c',
'test-memfd-util.c',
'test-memory-util.c',
@@ -134,6 +140,7 @@ simple_tests += files(
'test-path-lookup.c',
'test-path-util.c',
'test-percent-util.c',
+ 'test-pidref.c',
'test-pretty-print.c',
'test-prioq.c',
'test-proc-cmdline.c',
@@ -141,6 +148,7 @@ simple_tests += files(
'test-psi-util.c',
'test-ratelimit.c',
'test-raw-clone.c',
+ 'test-recovery-key.c',
'test-recurse-dir.c',
'test-replace-var.c',
'test-rlimit-util.c',
@@ -170,7 +178,7 @@ simple_tests += files(
'test-terminal-util.c',
'test-tmpfile-util.c',
'test-udev-util.c',
- 'test-uid-alloc-range.c',
+ 'test-uid-classification.c',
'test-uid-range.c',
'test-umask-util.c',
'test-unaligned.c',
@@ -178,6 +186,7 @@ simple_tests += files(
'test-user-util.c',
'test-utf8.c',
'test-verbs.c',
+ 'test-vpick.c',
'test-web-util.c',
'test-xattr-util.c',
'test-xml.c',
@@ -242,18 +251,12 @@ executables += [
},
test_template + {
'sources' : files('test-compress-benchmark.c'),
- 'link_with' : [
- libbasic_compress,
- libshared,
- ],
+ 'link_with' : [libshared],
'timeout' : 90,
},
test_template + {
'sources' : files('test-compress.c'),
- 'link_with' : [
- libbasic_compress,
- libshared,
- ],
+ 'link_with' : [libshared],
},
test_template + {
'sources' : files('test-cryptolib.c'),
@@ -262,7 +265,10 @@ executables += [
},
test_template + {
'sources' : files('test-dlopen-so.c'),
- 'dependencies' : libp11kit_cflags
+ 'dependencies' : [
+ libp11kit_cflags,
+ libkmod_cflags,
+ ],
},
test_template + {
# only static linking apart from libdl, to make sure that the
@@ -332,7 +338,7 @@ executables += [
},
test_template + {
'sources' : files('test-netlink-manual.c'),
- 'dependencies' : libkmod,
+ 'dependencies' : libkmod_cflags,
'conditions' : ['HAVE_KMOD'],
'type' : 'manual',
},
@@ -376,6 +382,10 @@ executables += [
'dependencies' : threads,
},
test_template + {
+ 'sources' : files('test-progress-bar.c'),
+ 'type' : 'manual',
+ },
+ test_template + {
'sources' : files('test-qrcode-util.c'),
'dependencies' : libdl,
},
@@ -475,7 +485,7 @@ executables += [
'sources' : files('test-bpf-foreign-programs.c'),
},
core_test_template + {
- 'sources' : files('test-bpf-lsm.c'),
+ 'sources' : files('test-bpf-restrict-fs.c'),
'dependencies' : common_test_dependencies,
},
core_test_template + {
@@ -525,7 +535,7 @@ executables += [
'parallel' : false,
},
core_test_template + {
- 'sources' : files('test-manager.c'),
+ 'sources' : files('test-taint.c'),
},
core_test_template + {
'sources' : files('test-namespace.c'),
@@ -579,12 +589,18 @@ executables += [
},
test_template + {
'sources' : files('../libsystemd/sd-device/test-sd-device-thread.c'),
- 'link_with' : libsystemd,
+ 'link_with' : [
+ libbasic,
+ libsystemd,
+ ],
'dependencies' : threads,
},
test_template + {
'sources' : files('../libudev/test-udev-device-thread.c'),
- 'link_with' : libudev,
+ 'link_with' : [
+ libbasic,
+ libudev,
+ ],
'dependencies' : threads,
},
test_template + {
@@ -594,4 +610,8 @@ executables += [
libudev_basic,
],
},
+ test_template + {
+ 'sources' : files('test-aux-scope.c'),
+ 'type' : 'manual',
+ },
]