summaryrefslogtreecommitdiffstats
path: root/src/ukify/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/ukify/test/meson.build')
-rw-r--r--src/ukify/test/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/ukify/test/meson.build b/src/ukify/test/meson.build
new file mode 100644
index 0000000..2df196b
--- /dev/null
+++ b/src/ukify/test/meson.build
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+if want_ukify and want_tests != 'false'
+ have_pytest_flakes = pymod.find_installation(
+ 'python3',
+ required : false,
+ modules : ['pytest_flakes'],
+ ).found()
+
+ args = ['-v']
+ if have_pytest_flakes
+ args += ['--flakes']
+ endif
+
+ test('test-ukify',
+ files('test_ukify.py'),
+ args: args,
+ env : test_env,
+ timeout : 120,
+ suite : 'ukify')
+endif