summaryrefslogtreecommitdiffstats
path: root/src/vmspawn/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/vmspawn/meson.build')
-rw-r--r--src/vmspawn/meson.build14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/vmspawn/meson.build b/src/vmspawn/meson.build
index 800d7c3..3cd9a3b 100644
--- a/src/vmspawn/meson.build
+++ b/src/vmspawn/meson.build
@@ -3,6 +3,9 @@
libvmspawn_core_sources = files(
'vmspawn-settings.c',
'vmspawn-util.c',
+ 'vmspawn-scope.c',
+ 'vmspawn-mount.c',
+ 'vmspawn-register.c',
)
libvmspawn_core = static_library(
'vmspawn-core',
@@ -16,6 +19,10 @@ vmspawn_libs = [
libshared,
]
+vmspawn_test_template = test_template + {
+ 'link_with' : [vmspawn_libs],
+}
+
executables += [
executable_template + {
'name' : 'systemd-vmspawn',
@@ -23,5 +30,10 @@ executables += [
'conditions': ['ENABLE_VMSPAWN'],
'sources' : files('vmspawn.c'),
'link_with' : vmspawn_libs,
- }
+ 'dependencies' : [libblkid]
+ },
+ vmspawn_test_template + {
+ 'conditions': ['ENABLE_VMSPAWN'],
+ 'sources' : files('test-vmspawn-util.c'),
+ },
]