summaryrefslogtreecommitdiffstats
path: root/test/TEST-06-SELINUX/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-06-SELINUX/meson.build')
-rw-r--r--test/TEST-06-SELINUX/meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/TEST-06-SELINUX/meson.build b/test/TEST-06-SELINUX/meson.build
index 7a850be..fd670ae 100644
--- a/test/TEST-06-SELINUX/meson.build
+++ b/test/TEST-06-SELINUX/meson.build
@@ -3,10 +3,14 @@
integration_tests += [
integration_test_template + {
'name' : fs.name(meson.current_source_dir()),
- 'cmdline' : integration_test_template['cmdline'] + ['selinux=1', 'lsm=selinux'],
+ 'cmdline' : integration_test_template['cmdline'] + ['selinux=1', 'enforcing=0', 'lsm=selinux'],
# FIXME; Figure out why reboot sometimes hangs with 'linux' firmware.
- 'firmware' : 'uefi',
+ # Use 'auto' to automatically fallback on non-uefi architectures.
+ 'firmware' : 'auto',
'vm' : true,
+ # Make sure we don't mount anything with virtiofs as otherwise fixfiles will try to relabel
+ # it.
+ 'mkosi-args' : integration_test_template['mkosi-args'] + ['--runtime-build-sources=no'],
},
]