summaryrefslogtreecommitdiffstats
path: root/test/TEST-13-NSPAWN
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-13-NSPAWN')
-rw-r--r--test/TEST-13-NSPAWN/meson.build8
-rwxr-xr-xtest/TEST-13-NSPAWN/test.sh8
2 files changed, 15 insertions, 1 deletions
diff --git a/test/TEST-13-NSPAWN/meson.build b/test/TEST-13-NSPAWN/meson.build
new file mode 100644
index 0000000..77370ce
--- /dev/null
+++ b/test/TEST-13-NSPAWN/meson.build
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+integration_tests += [
+ integration_test_template + {
+ 'name' : fs.name(meson.current_source_dir()),
+ 'vm' : true,
+ },
+]
diff --git a/test/TEST-13-NSPAWN/test.sh b/test/TEST-13-NSPAWN/test.sh
index 93af59e..9a0404f 100755
--- a/test/TEST-13-NSPAWN/test.sh
+++ b/test/TEST-13-NSPAWN/test.sh
@@ -5,13 +5,19 @@ set -e
TEST_DESCRIPTION="systemd-nspawn tests"
IMAGE_NAME="nspawn"
TEST_NO_NSPAWN=1
+IMAGE_ADDITIONAL_ROOT_SIZE=500
+TEST_FORCE_NEWIMAGE=1
# shellcheck source=test/test-functions
. "${TEST_BASE_DIR:?}/test-functions"
test_append_files() {
local workspace="${1:?}"
- local container="$workspace/testsuite-13-container-template"
+ local container="$workspace/usr/share/TEST-13-NSPAWN-container-template"
+
+ # For virtual wlan interface.
+ instmods mac80211_hwsim
+ generate_module_dependencies
# Create a dummy container "template" with a minimal toolset, which we can
# then use as a base for our nspawn/machinectl tests