summaryrefslogtreecommitdiffstats
path: root/test/TEST-55-OOMD
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-55-OOMD')
-rw-r--r--test/TEST-55-OOMD/meson.build3
-rwxr-xr-xtest/TEST-55-OOMD/test.sh2
2 files changed, 4 insertions, 1 deletions
diff --git a/test/TEST-55-OOMD/meson.build b/test/TEST-55-OOMD/meson.build
index adc0509..2566316 100644
--- a/test/TEST-55-OOMD/meson.build
+++ b/test/TEST-55-OOMD/meson.build
@@ -5,6 +5,9 @@ integration_tests += [
'name' : fs.name(meson.current_source_dir()),
'credentials' : integration_test_template['credentials'] + [
files('systemd.unit-dropin.init.scope'),
+ # OpenSUSE disables all controller delegation for the user manager template. Mask the
+ # dropin to make TEST-55-OOMD pass on OpenSUSE.
+ 'systemd.unit-dropin.user@.service~20-defaults-SUSE=',
],
'vm' : true,
},
diff --git a/test/TEST-55-OOMD/test.sh b/test/TEST-55-OOMD/test.sh
index 5e30963..3b2f471 100755
--- a/test/TEST-55-OOMD/test.sh
+++ b/test/TEST-55-OOMD/test.sh
@@ -14,7 +14,7 @@ TEST_NO_NSPAWN=1
test_append_files() {
local workspace="${1:?}"
- image_install mkswap swapon swapoff stress
+ image_install mkswap swapon swapoff stress-ng
image_install -o btrfs
mkdir -p "${workspace:?}/etc/systemd/system/init.scope.d/"