summaryrefslogtreecommitdiffstats
path: root/INSTALL.md
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--INSTALL.md35
1 files changed, 26 insertions, 9 deletions
diff --git a/INSTALL.md b/INSTALL.md
index b3fbf42..08fc31b 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -3,7 +3,7 @@ If you have not built libpcap, and your system does not have libpcap
installed, install libpcap first. Your system might provide a version
of libpcap that can be installed; if so, to compile tcpdump you might
need to install a "developer" version of libpcap as well as the
-"run-time" version. You can also install tcpdump.org's version of
+"run-time" version. You can also install The Tcpdump Group version of
libpcap; see [this file](README.md) for the location.
You will need a C99 compiler to build tcpdump. The build system
@@ -12,16 +12,34 @@ the generally available GNU C compiler (GCC) or Clang.
After libpcap has been built (either install it with `make install` or
make sure both the libpcap and tcpdump source trees are in the same
-directory), run `./configure` (a shell script). `configure` will
+directory), do the following steps:
+
+* If you build from a git clone rather than from a release archive,
+run `./autogen.sh` (a shell script). The autogen.sh script will
+build the `configure` and `config.h.in` files.
+
+On some system, you may need to set the `AUTORECONF` variable, like:
+`AUTORECONF=autoreconf-2.69 ./autogen.sh`
+to select the `autoreconf` version you want to use.
+
+* Run `./configure` (a shell script). The configure script will
determine your system attributes and generate an appropriate `Makefile`
-from `Makefile.in`. Now build tcpdump by running `make`.
+from `Makefile.in`. The configure script has a number of options to
+control the configuration of tcpdump; `./configure --help` will show
+them.
+
+* Next, build tcpdump by running `make`.
+
+On OpenBSD, you may need to set, before the `make`, the `AUTOCONF_VERSION`
+variable like:
+`AUTOCONF_VERSION=2.69 make`
-If everything builds ok, `su` and type `make install`. This will install
+If everything builds fine, `su` and type `make install`. This will install
tcpdump and the manual entry. Any user will be able to use tcpdump to
read saved captures. Whether a user will be able to capture traffic
depends on the OS and the configuration of the system; see the
[tcpdump man page](https://www.tcpdump.org/manpages/tcpdump.1.html)
-for details. DO NOT give untrusted users the ability to
+for details. Do **NOT** give untrusted users the ability to
capture traffic. If a user can capture traffic, he or she could use
utilities such as tcpdump to capture any traffic on your net, including
passwords.
@@ -29,11 +47,11 @@ passwords.
Note that most systems ship tcpdump, but usually an older version.
Building tcpdump from source as explained above will usually install the
binary as `/usr/local/bin/tcpdump`. If your system has other tcpdump
-binaries, you might need to deinstall these or to set the PATH environment
+binaries, you might need to deinstall these or to set the `PATH` environment
variable if you need the `tcpdump` command to run the new binary
(`tcpdump --version` can be used to tell different versions apart).
-If your system is not one which we have tested tcpdump on, you may have
+If your system is not one that we have tested tcpdump on, you may have
to modify the `configure` script and `Makefile.in`. Please
[send us patches](https://www.tcpdump.org/index.html#patches)
for any modifications you need to make.
@@ -62,15 +80,14 @@ ascii_strcasecmp.c - locale-independent case-independent string comparison
routines
atime.awk - TCP ack awk script
atm.h - ATM traffic type definitions
+autogen.sh - build configure and config.h.in (run this first)
bpf_dump.c - BPF program printing routines, in case libpcap doesn't
have them
chdlc.h - Cisco HDLC definitions
cpack.c - functions to extract packed data
cpack.h - declarations of functions to extract packed data
config.guess - autoconf support
-config.h.in - autoconf input
config.sub - autoconf support
-configure - configure script (run this first)
configure.ac - configure script source
doc/README.* - some building documentation
ethertype.h - Ethernet type value definitions