summaryrefslogtreecommitdiffstats
path: root/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/Makefile b/doc/Makefile
new file mode 100644
index 0000000..2271a40
--- /dev/null
+++ b/doc/Makefile
@@ -0,0 +1,17 @@
+PANDOC = pandoc
+MANSECTION = 1
+NAME = testssl
+TITLE = testssl.sh
+
+all: $(NAME).$(MANSECTION) $(NAME).$(MANSECTION).html
+
+force: clean all
+
+clean:
+ rm -f $(NAME).$(MANSECTION) $(NAME).$(MANSECTION).html
+
+$(NAME).$(MANSECTION): $(NAME).$(MANSECTION).md
+ $(PANDOC) --standalone --to man $(NAME).$(MANSECTION).md -o $@
+
+$(NAME).$(MANSECTION).html: template.html $(NAME).$(MANSECTION).md
+ $(PANDOC) --standalone --to html5 --template template.html --metadata title="$(TITLE)" $(NAME).$(MANSECTION).md -o $@