summaryrefslogtreecommitdiffstats
path: root/python/mozbuild/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /python/mozbuild/setup.py
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/mozbuild/setup.py')
-rw-r--r--python/mozbuild/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/python/mozbuild/setup.py b/python/mozbuild/setup.py
new file mode 100644
index 0000000000..30785493b0
--- /dev/null
+++ b/python/mozbuild/setup.py
@@ -0,0 +1,29 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+VERSION = "0.2"
+
+setup(
+ author="Mozilla Foundation",
+ author_email="dev-builds@lists.mozilla.org",
+ name="mozbuild",
+ description="Mozilla build system functionality.",
+ license="MPL 2.0",
+ packages=find_packages(),
+ version=VERSION,
+ install_requires=[
+ "jsmin",
+ "mozfile",
+ ],
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Software Development :: Build Tools",
+ "License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+ keywords="mozilla build",
+)