summaryrefslogtreecommitdiffstats
path: root/third_party/function2/Findfunction2.cmake
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/function2/Findfunction2.cmake
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/function2/Findfunction2.cmake')
-rw-r--r--third_party/function2/Findfunction2.cmake10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/function2/Findfunction2.cmake b/third_party/function2/Findfunction2.cmake
new file mode 100644
index 0000000000..ca1fc3e41f
--- /dev/null
+++ b/third_party/function2/Findfunction2.cmake
@@ -0,0 +1,10 @@
+# Makes it possible to find function2 through find_package(function2 REQUIRED)
+# when this source directory was added to the CMake module path.
+# For instance it could be done through adding this to the CMakeLists.txt
+# file in the parent directory:
+# ```cmake
+# list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/function2")
+# ```
+
+set(FU2_IS_FIND_INCLUDED ON)
+include("${CMAKE_CURRENT_LIST_DIR}/CMakeLists.txt")