summaryrefslogtreecommitdiffstats
path: root/third_party/rust/async-task/CHANGELOG.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/async-task/CHANGELOG.md
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/async-task/CHANGELOG.md')
-rw-r--r--third_party/rust/async-task/CHANGELOG.md81
1 files changed, 81 insertions, 0 deletions
diff --git a/third_party/rust/async-task/CHANGELOG.md b/third_party/rust/async-task/CHANGELOG.md
new file mode 100644
index 0000000000..d0a3e0be76
--- /dev/null
+++ b/third_party/rust/async-task/CHANGELOG.md
@@ -0,0 +1,81 @@
+# Version 4.3.0
+
+- Bump MSRV to Rust 1.47. (#30)
+- Evaluate the layouts for the tasks at compile time. (#30)
+- Add layout_info field to TaskVTable so that debuggers can decode raw tasks. (#29)
+
+# Version 4.2.0
+
+- Add `Task::is_finished`. (#19)
+
+# Version 4.1.0
+
+- Add `FallibleTask`. (#21)
+
+# Version 4.0.3
+
+- Document the return value of `Runnable::run()` better.
+
+# Version 4.0.2
+
+- Nits in the docs.
+
+# Version 4.0.1
+
+- Nits in the docs.
+
+# Version 4.0.0
+
+- Rename `Task` to `Runnable`.
+- Rename `JoinHandle` to `Task`.
+- Cancel `Task` on drop.
+- Add `Task::detach()` and `Task::cancel()`.
+- Add `spawn_unchecked()`.
+
+# Version 3.0.0
+
+- Use `ThreadId` in `spawn_local` because OS-provided IDs can get recycled.
+- Add `std` feature to `Cargo.toml`.
+
+# Version 2.1.1
+
+- Allocate large futures on the heap.
+
+# Version 2.1.0
+
+- `JoinHandle` now only evaluates after the task's future has been dropped.
+
+# Version 2.0.0
+
+- Return `true` in `Task::run()`.
+
+# Version 1.3.1
+
+- Make `spawn_local` available only on unix and windows.
+
+# Version 1.3.0
+
+- Add `waker_fn`.
+
+# Version 1.2.1
+
+- Add the `no-std` category to the package.
+
+# Version 1.2.0
+
+- The crate is now marked with `#![no_std]`.
+- Add `Task::waker` and `JoinHandle::waker`.
+- Add `Task::into_raw` and `Task::from_raw`.
+
+# Version 1.1.1
+
+- Fix a use-after-free bug where the schedule function is dropped while running.
+
+# Version 1.1.0
+
+- If a task is dropped or canceled outside the `run` method, it gets re-scheduled.
+- Add `spawn_local` constructor.
+
+# Version 1.0.0
+
+- Initial release