summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-backend/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/cubeb-backend/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cubeb-backend/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-backend/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-backend/Cargo.toml b/third_party/rust/cubeb-backend/Cargo.toml
new file mode 100644
index 0000000000..00bfada88c
--- /dev/null
+++ b/third_party/rust/cubeb-backend/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "cubeb-backend"
+version = "0.10.3"
+authors = ["Dan Glastonbury <dglastonbury@mozilla.com>"]
+description = """
+Bindings to libcubeb internals to facilitate implementing cubeb backends in rust.
+"""
+homepage = "https://github.com/mozilla/cubeb-rs"
+keywords = ["cubeb"]
+categories = ["api-bindings"]
+license = "ISC"
+repository = "https://github.com/mozilla/cubeb-rs"
+
+[dependencies.cubeb-core]
+version = "0.10.3"
+
+[features]
+gecko-in-tree = ["cubeb-core/gecko-in-tree"]
+
+[badges.circle-ci]
+repository = "mozilla/cubeb-rs"