summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-pulse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/cubeb-pulse/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cubeb-pulse/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-pulse/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-pulse/Cargo.toml b/third_party/rust/cubeb-pulse/Cargo.toml
new file mode 100644
index 0000000000..98e2e87dbf
--- /dev/null
+++ b/third_party/rust/cubeb-pulse/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "cubeb-pulse"
+version = "0.4.1"
+authors = ["Dan Glastonbury <dglastonbury@mozilla.com>"]
+description = "Cubeb backed for PulseAudio written in Rust"
+readme = "README.md"
+license = "ISC"
+
+[lib]
+crate-type = [
+ "staticlib",
+ "rlib",
+]
+
+[dependencies]
+cubeb-backend = "0.10.3"
+ringbuf = "0.2"
+semver = "1.0"
+
+[dependencies.pulse]
+path = "pulse-rs"
+
+[dependencies.pulse-ffi]
+path = "pulse-ffi"
+
+[features]
+pulse-dlopen = ["pulse-ffi/dlopen"]