summaryrefslogtreecommitdiffstats
path: root/third_party/rust/float-cmp/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/float-cmp/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/float-cmp/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/rust/float-cmp/Cargo.toml b/third_party/rust/float-cmp/Cargo.toml
new file mode 100644
index 0000000000..e3b9449603
--- /dev/null
+++ b/third_party/rust/float-cmp/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "float-cmp"
+version = "0.6.0"
+authors = ["Mike Dilger <mike@mikedilger.com>"]
+description = "Floating point approximate comparison traits"
+documentation = "https://docs.rs/float-cmp"
+readme = "README.md"
+keywords = ["float", "comparison", "fuzzy", "approximate"]
+license = "MIT"
+repository = "https://github.com/mikedilger/float-cmp"
+
+[lib]
+name = "float_cmp"
+path = "src/lib.rs"
+test = true
+doctest = true
+doc = true
+[dependencies.num-traits]
+version = "0.2"
+optional = true
+default-features = false
+
+[features]
+default = ["num-traits"]