summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/neqo-common/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/neqo-common/Cargo.toml')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
new file mode 100644
index 0000000000..93c58fe25f
--- /dev/null
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "neqo-common"
+version = "0.6.4"
+authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+build = "build.rs"
+license = "MIT/Apache-2.0"
+
+[dependencies]
+lazy_static = "1.3.0"
+qlog = "0.4.0"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["std"]
+default-features = false
+
+[dependencies.env_logger]
+version = "0.9"
+default-features = false
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["timeapi"]