summaryrefslogtreecommitdiffstats
path: root/third_party/rust/unic-langid-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:44:51 +0000
commit9e3c08db40b8916968b9f30096c7be3f00ce9647 (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/unic-langid-macros
parentInitial commit. (diff)
downloadthunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.tar.xz
thunderbird-9e3c08db40b8916968b9f30096c7be3f00ce9647.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/unic-langid-macros')
-rw-r--r--third_party/rust/unic-langid-macros/.cargo-checksum.json1
-rw-r--r--third_party/rust/unic-langid-macros/Cargo.toml42
-rw-r--r--third_party/rust/unic-langid-macros/README.md1
-rw-r--r--third_party/rust/unic-langid-macros/src/lib.rs17
4 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/unic-langid-macros/.cargo-checksum.json b/third_party/rust/unic-langid-macros/.cargo-checksum.json
new file mode 100644
index 0000000000..643d0d6039
--- /dev/null
+++ b/third_party/rust/unic-langid-macros/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"debce559451d7edd257495d2f7a8c3bd081e1ec15625d42668165cec8f2a4cf7","README.md":"6bab9883bd094c16d22f7aeddb59b391c1567c167ffed2f28aee9e2a82de1a1d","src/lib.rs":"f850878a5d545496073593ef1ca340ef385f78bc6585c5d3b46fe8ffc2087bd5"},"package":"055e618bf694161ffff0466d95cef3e1a5edc59f6ba1888e97801f2b4ebdc4fe"} \ No newline at end of file
diff --git a/third_party/rust/unic-langid-macros/Cargo.toml b/third_party/rust/unic-langid-macros/Cargo.toml
new file mode 100644
index 0000000000..55fad3cfc7
--- /dev/null
+++ b/third_party/rust/unic-langid-macros/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "unic-langid-macros"
+version = "0.9.1"
+authors = [
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Zibi Braniecki <gandalf@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "benches/*.rs",
+ "Cargo.toml",
+ "README.md",
+]
+description = "API for managing Unicode Language Identifiers"
+readme = "README.md"
+categories = ["internationalization"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/zbraniecki/unic-locale"
+
+[dependencies.proc-macro-hack]
+version = "0.5"
+
+[dependencies.tinystr]
+version = "0.7.0"
+
+[dependencies.unic-langid-impl]
+version = "0.9"
+
+[dependencies.unic-langid-macros-impl]
+version = "0.9"
diff --git a/third_party/rust/unic-langid-macros/README.md b/third_party/rust/unic-langid-macros/README.md
new file mode 100644
index 0000000000..4497b805d6
--- /dev/null
+++ b/third_party/rust/unic-langid-macros/README.md
@@ -0,0 +1 @@
+This is an internal macro declaration crate for `unic-langid`. Please use `unic-langid` instead.
diff --git a/third_party/rust/unic-langid-macros/src/lib.rs b/third_party/rust/unic-langid-macros/src/lib.rs
new file mode 100644
index 0000000000..9e075e15c0
--- /dev/null
+++ b/third_party/rust/unic-langid-macros/src/lib.rs
@@ -0,0 +1,17 @@
+use proc_macro_hack::proc_macro_hack;
+pub use unic_langid_impl::{subtags, LanguageIdentifier};
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::langid;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::lang;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::script;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::region;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::variant_fn as variant;